Introduction

In first...

This document is intended to guide you in using OMeR. Only OMeR features are explained here. Please refer to the specific documentation for Melody Assistant or Harmony Assistant for more details about these two programs.
OMeR can be used as well from Harmony or Melody.

In this manual, the term "Harmony-Melody" will mean any of these two programs.

What is OMeR ?

OMeR converts a printed musical score in a music file you can hear, modify and print with Melody Assistant or Harmony Assistant. If you often copy printed scores under Melody Assistant or Harmony Assistant, and you own a scanner; OMeR will greatly ease your job.
OMeR will drive your scanner, collect one or several pages and analyze them to generate a musical document usable directly under Melody Assistant or Harmony Assistant.

OMeR can be run as an independent program, but you'll need Melody or Harmony to view documents generated by OMeR.

OMeR is shareware. Go to this page to see the distribution mode.

Important : At the end of this document is the Software license chapter. You must read it before using the software.

Distribution

OMeR is shareware. A fee (US$20 or 20 euros) is asked for accessing the whole features.
This fee grants you a personal lifetime usage for present and future software versions. Updates are free of charge.

Unregistered version of the software enables you to test all the OMeR features. Generated documents will be complete, and identical to those from the registered version.

The only limitation is under Harmony or Melody Assistant, you'll be able to view or listen to documents created by OMeR , but you won't be able to modify, save or print them.

Note : Melody Assistant is shareware (US$20 or 20 euros). Harmony Assistant is a commercial program (US$70 or 70 euros).

Although not necessary, it's recommended to own a complete version of Melody or Harmony to use OMeR.

Question : What means "shareware"?
It means you can try OMeR for free.
If this program matches your requirements, you'll then be able to order a personal registration code

Required configuration


 
 

- A PC compatible under Windows (Windows 95 to 2000 or XP to 8) or
  a Macintosh  (Mac OS X 10.5 or more - PPC or Intel)

- Melody Assistant or Harmony Assistant already installed

- A scanner, preferably Twain-compatible

- Enough space left on hard disk to be able to store page pictures

Limits

OMeR doesn't pretend to be infallible. Optical Character Recognition (OCR) experiences the same problems than the human eye and can lead to the same mistakes.

Whatever the printed page looks like, probably some notes will be missing or erroneous. Don't forget OMeR is designed to assist you in entering music by processing the main part of the job, not its whole !

A personalized setup of OMeR parameters will probably reduce the error rate. (see chapter "Document setup")

OMeR has been optimized for a maximum speed. However, each time we had to choose an algorithm, recognition quality always prevailed over speed. On a 200 MHz computer, processing of a page with an average complexity is about 20 seconds.

Most important mistakes will occur on scores in poor condition, handwritten or using ancient typography. Manual touching up work will then be more important.
Ergonomics of Melody or Harmony Assistant will help you in this job.

In its current version OMeR processes :

In its current version, OMeR does not process :

What's new?

This page describes the successive improvements of OMeR, in chronological reverse order.
 

=> OMeR 2.3,  September 2013


- Minor bugfixes
- Windows: compatibility w/ Windows 8

=> OMeR 2.2,  October 2008


- Macintosh: Universal Binary version
- Windows: Vista compatibility

=> OMeR 2.1,  July 2004

• New manual version
• Miscellaneous minor fixes
• Better processing of some characters
• Mac OS X: Loading and processing JPG, GIF, PDF, PNG, Photoshop, targa,TIFF,etc file using QuickTime.
• Mac OS X: Loading and processing multi-pages PDF files.

Minor version 2.1.1
• You can change the color of areas in general setup. The default color is purple.
• Macintosh: Font problem fixed.
• Windows: Work around for a bug in some HP drivers.


=> OMeR 2.0.1,  October 2003

• Fix : drag and drop on Macintosh
• Fix : update problem while changing scale
• New panel in general setup : colors for computed notes.

=> OMeR 2.0,  September 2003

• Help to recognition : feature to add an area that forces a symbol in the computing process.
• Computation tool palette.
• + and - keys change scale. Spacebar runs page computation.
• Tutorials : You can view the tutorials from the web site or directly from the program.
• Fix : "6" symbol recognition in time signature.
• New chapters in the manual.
• OMeR document files are now located in "Myriad Documents/OMeR/Documents"
• OMeR result files are now located in "Myriad Documents/OMeR/Results"

=> OMeR 1.6, May  2003

• Update for Mac OS X.2
• Updated GUI
• First implementation of TWAIN system under Mac OS X
• New general setup : enables not to load the previous document at startup
• New document setup : don't compute stem size.

NOTE about TWAIN and Mac OS X.
The TWAIN system allow a standard management of scanning devices.
With Mac OS X , the TWAIN is located in the system folder : System/Library/Frameworks/ TWAIN.frameworks.
TWAIN  is installed by default with Mac OS X.2 (Jaguar)
The TWAIN driver specific to your device must be installed in :"Library/Image Capture/TWAIN Data Sources"
You will find the TWAIN driver on the scanner manufacturer site.

=> OMeR 1.5, September  2001

• Miscellaneours fixes and enhancements
• Now processes incomplete (shorter) staves at document end
• First version for Mac OS X. As Twain driver are not available on Mac OS X, you ought to scan with your standard scanning program.
• The 68 K version is not  supported anymore.
 

=> OMeR 1.4, April  2001

• You can now define areas to be ignored on page : texts, diagrams, etc. Click on the picture to add an area, Shift+click (or right click on PC) to delete it. Areas can also be moved and resized. Areas are saved with the document.

=> OMeR 1.3.1, Mars  2001

• Fixed compatibility problems with Mac OS 9.1

=> OMeR 1.3, December 2000

• Fixed Miscellaneous problems.

=> OMeR 1.2.3, June 2000

• You can now use the Photoshop© acquire plug-ins PPC to scan from OMeR

=> OMeR 1.2, 11/23 1999


• You can now use the Photoshop© acquire plug-ins to scan from OMeR


=> OMeR 1.1, 11/10 1999

•Compatibility with Melody 4.1 and Harmony 6.1 : key change at any location.
• Problem with some Twain drivers (Canon, Mustech...) fixed.

 => OMeR 1.0.7, 9/16 1999


 

=> OMeR 1.0.6, 9/15 1999

 => OMeR 1.0.5, 9/13 1999

(first CDROM version)

=> OMeR 1.0.4, 9/10 1999

=> OMeR 1.0.3, 9/9 1999

=> OMeR 1.0.2, Sept 7th 99

=> OMeR 1.0.1, Sept 9th 99

=> OMeR 1.0.0, september the 1st  1999


Updates

OMeR will be updated frequently, free of charge.

These updates are independent from those of Melody or Harmony. Visit frequently our Web pages :"http://www.myriad-online.com/cgi-bin/download.pl?lang=EN" to download the latest versions of our programs.

If you don't own an Internet access, you can order a CD-ROM including the latest versions of all our software (Harmony, Melody, OMeR, etc.) for US$10 or 10 euros, shipping included. On this CD-ROM you'll find too several hours of sample tunes and video tutorials.
 

Software Setup

This is the general setup for the software. It defines the whole software behavior. To define it, use the "File" menu, "Preferences" option.

"Factory" button sets the default value for all the thumb indexes.

Software setup window groups options by theme. Click on the thumb index or on button to change theme.
 

General (General Setup)

This setup defines how OMeR will react.

Scanner (Twain Configuration)

 This setup define how OMeR use the Twain protocol.

Save (File Saving setup)

When you ask OMeR for computing a complete document or a single page, a "msf" result file is created in the "Results" folder. You can load this file from Harmony-Melody, but also ask for the file to be loaded automatically as soon as Harmony or Melody is activated.
You can therefore ask for Melody-Harmony to be activated and the document loaded, viewed and played as soon as it is processed.
Advice: It is highly recommended to select this automatic activating option. Doing so, you'll switch automatically to the editing mode of Harmony or Melody as soon as OMeR has computed a document, and you'll then be able to listen, modify or print the result.
(modifying or printing the generated file needs your OMeR copy to be registered)

Document setup

This is the general document setup.

Independent settings are associated to each document. The document setup window is opened by "Document>Configuration"

Document setup window groups options by theme. Click on the thumb index or on button to change theme.

You can apply parameters defined for a saved document to the current one by clicking "Import", and selecting the document you want to use settings. It enables you to create a palette of different settings which can be applied to new documents.

"Preset" button sets the original preset value for all the thumb indexes.

"Default" indicates the current settings will be used by default when creating a new document.

Signature (Configuring signature analysis)

Symbols (Configuring notes analysis)

Launching OMeR

It is recommended to launch OMeR from Melody Assistant or Harmony Assistant by using File>Scan with OMeR. Thus, all generated files will be displayed and transformed in music documents as soon as the application is activated again. Application activating can be automatic (see OMeR's general setup)

You can also run OMeR as an independent application. Each converted page or document will be saved with the ".msf" extension in the OMeR's "Results" folder.

Melody Assistant or Harmony Assistant can load "msf" documents generated by OMeR. Do do this, select "File>Import>OMeR file", move to the OMeR's result folder (My Documents/Myriad Documents/OMeR) and select an "msf" document in the file list.
 

Tip : In the "Your name/Myriad Documents/OMeR" folder you will find a "Demos” folder with some samples.
You can try them on your computer.

OMeR's interface

On screen, you can see :

Menu bar

Apple menu on Mac or "?" on PC

"File" menu

    Note for Macintosh users :
    As you can seen we tried to make the Windows' interface as close as possible as it is on Macintosh, not to disconcert users who switch from a computer to another. In the same way, we recommend you to use the file extensions, even if not necessary on Macintosh.

"Edit" menu

"Document" menu

"Page" menu

"Windows" menu

"Page"

hide/show the window showing the current page.

"Document"

hide/show the window showing the document.

"Tutorials"

hide/show the window showing the tutorials

"Area Tools"

hide/show the area tool palette. Areas enable you to force the computation of symbols. This is described later in the "Improving recognition" chapter.


"Computation Tools"

 hide/show the computation tool palette.

"Increase scale"

increase the scale used to display the current page.

"Decrease scale"

decrease the scale used to display the current page.

"Full screen"

the window where is displayed the curret page will take up the full screen.

"See all"

 compute the scale view in order to see all the page.

"Original size"

set the scale view to 1.

"Gray image"

set the image color to gray in order to see the computation results more readable.

"Show result"

after computation, show/hide the computation result.

"Show removed symbol"

after computation, show/hide symbols recognized by OMeR but removed. These symbols are displayed in orange..

The windows

A document window

A page window



First step

making a picture file

 

OMeR uses pages saved in BMP, PICT or TIFF format. The default format on Macintosh is PICT, and on Windows, BMP.

To obtain such picture files, you can use an external scanning software. If your scanner is Twain compatible (which is probably the case), it's more easy to scan your page directly from OMeR.

In any case, rules below must be followed :

• Only one page in each picture file, but as many pages you want in a document.

• Use an original with a good quality
Use preferably a printed score (not handwritten) of white background, with well drawn symbols. Avoid copies of copies, on which printing quality may have been altered. Ensure horizontal and vertical lines are not broken.

If possible, avoid too "heavy" scores, on which texts, chord diagrams or dynamics are printer too close to the staves : these symbols may disturb OMeR.

Tip : Some printed score use a thin paper which let show the other side by transparency. These "ghosts" can disrupt OMeR processing.
So, put, on the scanned page, a black paper. All the background will be uniformly white.

• Scan pages in 200 dots per inches (dpi). With a lower resolution, result won't be as good, with important risks of mistake. A greater resolution will increase the computing time unnecessarily.

    Warning : Some scanners let you choose the scaling factor. Always select 100% because other values change the resolution !

 

If resolution is too low, an alert message will be displayed.

Tip : To check whether the scanning resolution is correct, load the image with a picture editor, and count the number of white pixels (graphic dots) between two horizontal lines of a staff. This value must be between 12 and 16.
If under 12, increase the scanning resolution, over 16 decrease it.

• Scan in black and white.
It's not necessary to scan in colors or gray levels, because the image will be converted in black and white by OMeR before being used.

From OMeR, select "Document>Scanner : Acquire". The Twain driver will display its standard box. Configure the scanner to scan the full page in black and white, with a resolution of 200 dpi. It's recommended to crop your picture to a avoid unneeded margins, and to check staves are horizontal.
Ensure also the page is well pressed on the scanner glass, in particular when you scan pages from a book.

OMeR is however very tolerant : special algorithms will process non-horizontal or distorted pages.

We recommend you to choose carefully you driver settings because quality, and so accuracy of the final result will depend on it. Don't hesitate to explore all the options of your Twain driver and to ask for a preview each time.

Start the page scanning process. As soon as completed, picture is quickly analyzed and a quality diagnosis is performed. Depending on the settings in “ File>Preferences>General ” this diagnosis will be displayed in the page window title and/or a dialog box will display details of the analysis.

OMeR works the same way your eye do : if you have difficulties reading a page because lines are broken or musical symbols are altered, OMeR will have too, and the result won't be good.

Tip : Most of scanner drivers enable to save their settings. Do it as soon as you find a satisfactory configuration.

Once page is scanned, a name is asked for this picture file (“bmp” extension on Windows and PICT on Macintosh “pct” extension)

This page is automatically added to the document's page list.

Tip : Save all pages from a same document in a unique folder, and give each page picture file the name of the score followed by the page number.

Check the quality of the result
If you get something like :
(picture scattered with black dots)
try to scan again your page, after having decreased the threshold level, if your scanner driver enables it.
Otherwise, turn the "dust removal" on.


If you get something like :
(lines too fat)
scan again your page, after having decreased the threshold level.


If you get something like :
(broken straight lines and/or white dots in black areas)
scan again your page, after having increased the threshold level, if your scanner driver enables it.
Otherwise, turn the "dust removal" on.
 

Second step 

Building a document



A musical document is usually made of several pages. Each page is stored in an independent file. Names of these pages are stored in an OMeR file, with "lsf" extension (List of Scan Files).

To help you managing these pages, each page appears as an icon in the page list. Current page is surrounded in red and viewed in bigger size in the main window.

Moving and deleting pages in a document

Copy/paste rules applies to this page list. <>Thus :
To insert a page : click between the previous an next page. An horizontal red line shows the insert location. Select then Document>Add page to insert a page from an existing picture file, or Document>Scanner : Acquire to acquire it from your scanner. Page will be added at this location.

Tip : You can use drag & drop to add a picture file to your document. Select a file on the desktop and drop it on an OMeR window.

To delete a page : click on the page icon. It becomes the current page. Select then Edit>Cut or Edit>Erase.

To move a page : click on the page icon. It becomes the current page. Select then Edit>Cut. Then click in the list on the location you want the page to be inserted. Select Edit>Paste.

You can undo the last operation by Edit>Undo.

Special processing

You can select special processing to each page :

Invert Black/White : if your scanner inverts white and black, it reverses it (black symbols on white background are necessary for your page to be processed).

Rotate : if your page hasn't be scanned in the right direction, you can rotate it.

Dust removal : erases little dots which can disturb recognition. Dust removal strength can be adjusted.

Threshold : if your page has been scanned in color or gray levels, defines from which value gray is considered as black. Threshold level can be adjusted.

Erase margins : if black areas are surrounding your picture, erases them. Erased area appears in light yellow.

These options are stored in the "lsf" document and applied to page before being processed. Processing result is showed in the main window. Since these options are applied each time page picture is loaded, they can noticeably slow down OMeR.

Third step

Processing a document

 

You can ask for processing only one page or the whole pages in the document. Select Compute>Compute page or Compute>Compute document.
 
 An information box about processing status is opened.

You can abort processing by clicking Cancel. Processing will be aborted and no result file will be generated.

Once computing is over, a result file with "msf" extension is generated in the OMeR's Results folder.

• If you process a single page only, name of result file will be the name of  page with "msf" extension.
• If you process the whole document, name of result file will be the name of  document with "msf" extension.

As soon as processing is completed, recognized symbols appear in green in the main window. These symbols will be present in the document loaded by Melody/Harmony.

Recognized symbols but which needed to be changed are displayed in orange. These symbols will be present in the document loaded by Melody/Harmony.

Recognized symbols but which needed to be removed are displayed in red. These symbols will not be present in the document loaded by Melody/Harmony.

You can setup these colors in the OMeR preferences.

The fourth step will explain some tips to avoid these symbols to be removed. You can enable or disable the display of these symbols from the "Windows" menu.

If you activate Harmony Assistant or Melody Assistant now, latest generated files will be automatically loaded and displayed.

You can configure in "File>Preferences" which files will  be loaded automatically.
 

Tip : You can compute one staff only: click on it with Ctrl (PC) or Apple (Mac) key down.
 

Fourth step 

Improving recognition

 

When you view or  listen the result of an OMeR computation with Melody/Harmony, you can find some  lacking symbols.

This can be improved.

Areas

We are going to see here how to use "areas" to help OMeR in its recognition process.

For example, if OMeR misses an accidental, you can use the Inject tool in
Melody/Harmony to add the accidental at the right place.

But if OMeR does not recognize the time signature, this will disrupt the whole computation because many symbols will be shifted or omitted to match the wrong time signature.
In the same way; some elements like text or dynamics can disrupt OMeR and generate a result that cannot be easily amended using Melody/Harmony.

Reminder : symbols that are recognized by OMeR but removed later in order to match the page setup are displayed in red. Symbols recognized by OMeR but modified later in term of duration are displayed in orange.

To avoid this, we can use substitution areas. An area defines a special behavior of the computation at a given location. Areas are saved along with the document.
You can open the Area palette using "Windows>Area tools"
You can delete all the areas in a page using "Areas>Delete all areas in this page"

This palette provide several editing modes :

add an area

remove an area

move and resize an area

The right part of the window defines all the symbols you can add using the add mode.

Use the horizontal scroll bar to browse the symbols.

Tip : To remove quickly an area without switching in remove mode, click the area with the shift key down (or using right mouse button)

Deactivating image parts

If the image include graphics that can disrupt OMeR (lyrics, annotation, dynamics...) they can be removed from the computation by using the

tool, then clicking on page. This part will not be processed.

Helping symbol recognition

Select the symbol in the palette. Then, click the page, keep the mouse button down and define the area. The symbol is displayed in red color, centered on the area. When computing, the computed symbol will be substituted by the one you defined.
Please note, you don't have to adjust accurately the "forced" symbol. Even a very small intersection is sufficient.
On the other hand, you cannot add a symbol where there is nothing on the page, or use an area to change a note pitch.
(See the step by step video tutorial about this topic.)

Helping barline recognition

When a vertical barline is not recognized by OMeR, the two bars will be merged into one.  We can notice this looking at the bar number displayed by OMeR after computation. Generally, when this happens, notes of the two bars cannot fit into only one bar so some notes are removed (displayed in orange).
The best way to avoid this error, is to add a bar line at the right position.
(See the step by step video tutorial about this topic.)

Helping time signature recognition

If the time signature is not correctly recognized, bar duration will be wrong and symbols will be removed (in orange). As we saw in a previous chapter, we can force time signature using the general document setup. We can also use areas to add the right numbers at the right place.
(See the step by step video tutorial about this topic.)

Fine computation adjustment

Some computation setup are pre-adjusted to a medium value, suitable for a majority of scores. The computation palette (Windows>Computation tools) enables to adjust these settings to your score. These adjustments are saved in the document.

Beam width

If beams are not found, particularly with multiple lines, or if OMeR finds beam where there is not, you can adjust this value.
(See the step by step video tutorial about this topic.)

Maximum beam tilt

OMeR do not compute thick lines with a big tilt. You can adjust this value here.
 

Tip : Video tutorials show you, step by step, many of the basic concepts introduced here : "Windows>Tutorials"

 

How to order 

To order a software license and thus access to the whole features, use the order form included in Melody Assistant, Harmony Assistant or OMeR .

Direct payment in cash


You can also send us a post mail including your name and address and your hardware configuration, along with your payment of 20 euros or US$25 by using the order form below. Note however that sending cash by post mail is not secure. When possible, please use another payment method.

First name:
Name:

Address:
City :
State/ZIP:
Country :
e-mail (optional) :

I order OMeR for : ( ) Macintosh   ( ) Windows

I already own : ( ) Melody Assistant  ( ) Harmony Assistant
The five first characters of my registration code are : _ _ _ _ _

()  I do not own neither Melody nor Harmony Assistant

I discovered OMeR :

( ) On a magazine CD-ROM :
( ) On the Web
( ) A friend told me about it
( ) Other (please precise) :

My remarks :
 

Send back this form, along with your payment of 20 euros or US$25 to :
Myriad,
26 rue Michel de Montaigne
F-31200 Toulouse
France

International postal money order

 
Account owner name :    Myriad  
Account owner address : 26 rue Michel de Montaigne
                        31200 Toulouse, FRANCE
 
Account number (IBAN) : FR 75 20041 01016 0652487S037 64

Bank Identifier Code (BIC or SWIFT): PSSTFRPPTOU
Account address       : La Banque Postale
                        Centre de Toulouse
                        31900 Toulouse Cedex 9
                        FRANCE

 
Important :
Please ensure that your money order can be cashed in France.

For example, US Postal Service's money orders are NOT accepted in France.

Anyway, please also send us by regular or electronic mail your coordinates (or printed registration form) and reference of your money order.

 

Secure payments via credit card


If you live in France or Europe (euro currency), go to :

http://www.myriad-online.com/cgi-bin/secureorder.pl?lang=1&from=1

If you live in another country, you can pay in US dollars through :
http://www.myriad-online.com/cgi-bin/secureorder.pl?lang=1&from=3



Note: 
Processing of your credit card on the Internet can take a few hours. After this delay, you will receive a confirmation message, saying your order has been taken into account.
You will then receive your registration code.

After your payment is received, we send back your personal registration number.

Then run OMeR and enter your name and address and this registration number in the code input window then OK.
Your copy is now registered, and you won't have to enter your code anymore, even if you install a new version of OMeR.

You are personally responsible for this code, and must ensure its confidentiality.
If you sell your computer, unregister your copy by using "?>Unregister my copy"(PC) or "Apple>Unregister my copy" (Macintosh).

Uninstall

On Macintosh

After having checked that no important document file has been saved in the OMeR folder, drag and drop the OMeR folder on trash can and empty it.

On Windows

From the Windows Start Menu, in the OMeR's program group, launch "Uninstall"

OMeR also installs a font in your system font folder : "Myriad Music Font" (Macintosh)  or "SToccata" (PC). This font is needed by all our programs : Harmony, Melody, OMeR. Delete it only if none of these programs is installed on your computer.
 

Technical Information

File types used by OMeR are :

• Picture files in  BMP, PICT, TIFF format. TIFF files are slower to load, and use more memory. Use instead BMP or PICT files if possible.

• OMeR document files. Document files store the document's page list, as well as associated special processing. In this file is also stored the software setup for this document. Document file names are followed by "lsf" extension (List of Scan Files).
A document file doesn't include page pictures, but only a link to their name on your hard disk. Thus, don't move or delete picture files composing this document.

It's recommended to create a folder for each document, containing the whole page picture files as well as the matching "lsf" file.

• OMeR result file. This file is generated by OMeR and automatically or manually loaded by Melody Assistant or Harmony Assistant. Extension for these files is always "msf" (Music Scan File). OMeR generates these files in its "Results" folder.
 

Lexicon

Appoggiatura (or Grace note)  : This is a little note, placed before another note which steals its time from the note it is linked with.  When several appogiatura are linked to a note, they are called Grace notes.

Dust removal : Erases little dots on picture.

OCR: Optical Character Recognition.

Pixel : picture dot

dpi : Dot Per Inch. Number of image dots (or pixels) per inch. 200 dpi means a 1"x1" square will contain 40,000 pixels.

Resolution : Image size in pixel and in number of possible colors per pixel

Scanner : Picture input device, which transforms a printed page in digital data for being process by software.

Threshold : Used to transform a gray scale picture in black and white. Separation level between black and white.

Twain : Data exchange standard between scanner and software applications. On PC, almost all scanners are Twain compatible. On Macintosh, some old Apple specific scanners don't follow this standard.

Frequently Asked Questions

Question : OMeR does not process well the time signature (3/4, 4/4) or the key signature (sharp and flat symbols near the clef). Can I improve this ?
Use Document>Configuration, Signature : manual. At the beginning of the recognition process, you will be asked for  key and time signature.
 
Question : How to print the whole manual?
Select "Printable Manual" in the left frame of this screen. Then, print the page with your web browser (File>Print).
 
Question : On a page, bars have not been taken into account. What can I do ?
Ensure your page is horizontal. If not, acquire it again.
Check whether extra drawing (Lyrics, annotations, chord diagrams...) are present between staves. If yes, erase them with a picture drawing program.

Question : How to know whether my scanner driver is Twain-compatible ?
Several  solutions :
• Read your scanner user's manual
• Try to call the driver from OMeR ("File> Scanner:Acquire")
• On Windows, file "c:\windows\twain_32.dll" must be present in your system folder
• On Mac OS X, the TWAIN driver specific to your device must be installed in :"Library/Image Capture/TWAIN Data Sources". If a TWAIN driver is not provided with your scanner, you can use SANE : http://www.sane-project.org/


Question : I've made a document including several pages, and I want to move it to another folder or another computer.
How to do this ?
To ensure all pages in the document will be found, copy them at the same level as the "lsf" file. You can transfer your files between Windows and Macintosh without any conversion, because file formats are compatible.
Questions : Some musical symbols are ignored by OMeR. What can I do ?
or : Some musical symbols are added by OMeR. What can I do ?
1) Check the good quality of your picture (see chapter "Making a picture file")
2) Check your document setup (see chapter "Document setup”)
 
Question : At the end of each staff, OMeR adds en empty bar. How to remove it ?
1) Ensure you asked for margins erasing.
2) Check whether there are dots or lines on the right of your picture, and if necessary erase them with a picture drawing program.
 

Question : Scanned image is displayed in light yellow on white background, or in white on black bckground. What may I do ?
The picture acquired by your scanner is in reverse contrast. You can select option "Invert black/white" in "Page" menu, or while scanning your page, selecting a black on white contrast in your scanner driver.

Question : How to speed up processing ?
OMeR processing time depends on your computer speed and the amount of operations on each picture.

To speed up the software interface you can disable diagnosis each time a new page is loaded (see chapter software setup)
You can also try to disable some image processing options like dust removal or margins elimination.

Processing speed itself can be increased by asking not to find tuplets, ties or effects (see chapter document setup).
We hope to be able to speed up processing in the next releases.
Question : Each time I try to scan a page, an error is displayed. What can I do ? OR
I start scanning a page and nothing happens. What can I do ?
With another software, try to acquire a page with the same parameters than under OMeR to check your scanner configuration.
With OMeR, try to unselect option "Enhanced mode" in the "Twain" thumb index of  software setup.
If it still does not work, send us a problem report.

Problem report

Before all :

 If you have a scanning problem with OMeR :

 If you have an image recognition problem :

 

How contact us ?

Software license

Evaluation or unregistered version

Non-profit distribution of the unregistered version of OMeR is acceptable without prior written notice, providing that the software is not modified in any way, and is distributed in its entirety (this includes the application, data files, and all accompanying documentation).
For-profit distribution of the above software requires a prior agreement from the authors, by post, fax or e-mail.

Complete or registered version

By purchasing the registration code for OMeR, the user accepts the present software license.
The registered version of OMeR is signed to its owner, becoming personal and confidential. Neither the registered copy of the software, nor the personal registration number can be distributed in any form. The registered user is fully responsible for the non-distribution of his personal registration number or his registered copy of the software.
License is not limited in time.
License is valid for one computer. If you want to install a registered version of OMeR on several computers, please contact us for purchasing a site license.

Disclaimer

In no event will Myriad, its officers, directors, employees or agents be liable for any special, incidental, or consequential damages resulting from possession, use, or malfunction of one of their product.
Neither exchange, nor partial or total refund will be claimed for these products after the user read his personal registration code.
Myriad reserves the right to invalidate and to lock at any moment the personal registration code of an user following upon an illegal distribution of his code or a default in the complete payment of his software license.
In no event will Myriad be liable for any direct or indirect consequence of the invalidation and locking of a personal registration code following upon a default in the payment or an illicit distribution of the personal code.

Greetings

We wish to thank here the  "TWAIN Working Group Committee" which provided an excellent documentation, allowing them to implement Twain dialog within OMeR.

We wish to thank too the Beta test crew members :

 Joël Bez
Hugo Biasini
Serge Botte
Claude Bouhallier
Yvon Brun
Michel Caby
Jean Canal
 Guy Cambia
Gilbert Dennery
Alain Desautez
Hervé Doreau
Pierre Dudez
 Bertrand Duma
Denis Duret
Joe Ercolino
Carole Isberie
Jean-Louis Joyaud
Jean-François Laplume
Xavier Laverdant
Claude Le Faou
Jean-Claude Le Guen
Francis Martin
Günter Mayer
Laurier Nappert
Christian Pointet
Philippe Vallier
Thierry Zwiernik