Página anterior    Melody Assistant    Página seguinte 
 

Introdução
Produtos
What's new ?
Manipulação
Notação
Escutar
Introdução
Regras
Efeitos/Expressão
Ajustamento Microtonal
Afinação alternada
Processadores de efeitos
Curvas de parâmetros
Instrumentos Personalizados
Pistas de Audio Digital
Jukebox
Karaoke
Dispositivos/scripting
Virtual Singer
FAQ
Licença de utilização
Ajuda Técnica
Apêndice
Impressão do Manual


Novo capitulo : Em Inglês :

 

Pistas de Audio Digital


Pistas de audio digital permitem-lhe armazenar dados de audio como sons digitais em vez de símbolos musicais.

Uma pista de audio digital é como uma cassete gravada que pode ser incluída num documento musical e no qual pode gravar o que quiser para emitir posteriormente.

O número de pistas digitais de audio num documento é ilimitada. Mais aínda, você pode usar simultaneamente pautas normais (emitindo na saída digital ou MIDI) e pistas de audio digital no mesmo documento.

Nota : O processador de efeitos digitais também pode ser aplicado às pistas de audio digital...

As pistas de audio digital permitem-lhe, por exemplo :
  • Adicionar a sua própria voz, ou uma parte instrumental tocada por si, no seu documento.
  • Gravar uma canção de um CD audio, eliminar a voz do cantor, e substítui-la pela sua.
  • Importar amostras em diferentes formatos (AIFF, WAV, MP3, SND) para inclusão nas suas composições.
  • Exportar o produto final em qualquer dos formatos digitais mais comuns e criar o seu próprio CD audio.
  • etc...
Veremos neste capítulo como configurar o seu computador, e os fundamentos da edição de pistas de audio digital.

Sumário :

Ajustando a memória

Ajustando a entrada digital
Adquirir e importar dados digitais
Validar
Editar
Dicas e sugestões


Ajustando a memória

As pistas de audio digital são armazenadas pelo Melody/Harmony no formato 44 kHz, 16 bits, mono (qualidade CD).
Uma gravação estéreo será partida em duas pistas de audio digital, uma para o canal esquerdo, a outra para o canal direito.

Isto significa que para um segundo de gravação em estéreo, 176400 bytes (172 Kb) serão armazenados.
Uma música de cinco minutos ocupará portanto cerca de 50 Mb de memória.

Este enorme volume de dados será tratado em ficheiros temporarios armazenados no seu disco duro ou, se assim o desejar e tiver memória suficiente, em RAM.

O modo como o programa controla as pistas de audio digital pode ser ajustada em "Configuração>Configuração Global>Digital".

É importante ajustar estes parâmetros adaptando-os ao hardware do seu computador, de modo a ganhar um acesso mais rápido aos dados de audio digital.Quando re-emitir, Melody/Harmony deverá ser capaz de ler os dados digitais a 172 Kb/sec.

O primeiro valor a ajustar é o tamanho do buffer de transferência. Esta memória é usada para a saída do som e para operações de cópia no modo de edição. Quanto mais alto for o valor, mais rápidas serão as operações carregar, guardar, converter e cortar/colar serão. Esta memória é parte da alocação privada de memória da sua aplicação. Um valor óptimo encontra-se no intervalo 512 a 1024 Kb.

Você pode seleccionar a localização temporária dos ficheiros. Os ficheiros temporários são usados para armazenar pistas, assim como "anular" operações enquanto no modo de edição. É recomendado um espaço em disco de pelo menos 100 Mb, mesmo mais se você estiver a trabalhar em ficheiros grandes com um grande número de níveis de anulação (veja configuração global).
Se tiver vários discos duros ou várias partições, seleccione a mais rápida ou com menos dados. É recomendado que defragmente este disco regularmente para optimizar a velocidade de transferência. (Veja o manual do seu computador)

Usar memória Temporária : se esta opção estiver seleccionada, o programa armazenará todos os dados que for possível na memória temporária (RAM) antes de usar o disco duro. Se tiver uma quantidade grande de memória (mais de 64 Mb), a velocidade de processamento poderá ser drásticamente aumentada.

Para o ajudar a optimizar os valores destes parâmetros tendo em atenção as especificações do seu computador, o botão "Verifique o meu computador" inicia um procedimento de testes e apresenta-lhe o resultado.



Ajustando a entrada digital

As fontes de gravação podem ser, por exemplo, um CD audio na unidade de CD-ROM, ou um microfone ligado ao seu computador.

Nota : A fonte de gravação (microfone, Leitor de CD, Aux, etc...) não é seleccionado no Melody-Harmony, mas sim usando as ferramentas de sistema padrão (Misturador de Audio no PC, painel de control "Som" control panel no Macintosh)

O menu "Configuração>Configuração entrada digital" define o modo como o Melody/Harmony adquire os dados da fonte de audio.

Se uma entrada digital está seleccionada e recebe dados, o medidor verde (no lado esquerdo da janela) deverá mover-se.

A entrada pode ser feita em mono ou em estéreo. Quando a entrada estéreo está seleccionada, duas pistas digitais de audio serão criadas uma por baixo da outra. A primeira é o canal esquerdo, a segunda o direito.
Se estiver a gravar de um microfone, não há maneira de seleccionar "estéreo".

O ganho (só disponível em alguns computadores) pode ser ajustado : isto é o factor de amplificação, automático ou manual, aplicado ao sinal de entrada de audio.

O atraso de entrada permite-lhe compensar o tempo de processamento para o seu computador, porque pode existir um atraso entre o tempo de um sinal de audio que é fornecido ao computador e o tempo que corresponde à disponibilização dos dados digitais pelo conversor analógico-digital.
O Melody/Harmony ajusta automaticamente um atraso base que é dependente dos parâmetros definidos para a saída digital (veja a janela de configuração de saída digital). O atraso de entrada é então adicionado ou subtraído deste atraso base.
Por exemplo, se gravar a sua voz numa pista de audio digital enquanto a música está a tocar, um atraso de alguns milisegundos entre a voz gravada e a música pode ocorrer quando o item for repetido.

Aqui está um método simples para obter o valor correcto para o atraso de entrada :

  1. Crie um documento vazio com cerca de doze compassos.
  2. Active o metrónomo na paleta "Ferramentas de Emissão".
  3. Inicie a gravação e grave directamente, com um microfone, o som do metrónomo emitido pelos alto-falantes do seu computador durante cerca de dois ou três segundos.
  4. Adicione o resultado ao seu documento.
  5. Se o tempo de atraso estiver correctamente definido, o cliques do metrónome ocorrerão exactamente no inicio de cada compasso.
  6. Se os cliques se ouvirem um pouco antes (à esquerda da barra divisora do compasso) incremente o atraso de entrada e tente novamente.
  7. Se os cliques se ouvirem um pouco mais tarde (à direita da barra divisora do compasso) decremente o atraso de entrada e tente novamente.
A entrada digital está correctamente configurada.
Se alterar os parâmetros de saída digital, poderá ser necessário executar esta configuração novamente.




Adquirir e importar dados digitais


Nota : Para gravar uma pista de audio digital, torne visivel a paleta "Ferramentas de gravação" (Menu "Janelas"). Depois seleccione os tipos de entrada : digital e/ou Midi. Por favor tenha em atenção de que estes dois tipos de entrada podem ser seleccionados ao mesmo tempo, permitindo-lhe gravar o que estiver a tocar num teclado electrónico enquanto canta usando um microfone.

Nota para os utilizadores do Windows: Antes de iniciar uma gravação digital, você deve seleccionar um dispositivo de entrada digital em "Configuração>Configuração de Hardware".
Existem várias maneiras de incluír uma pista de audio digital num documento musical.
  • Importando um ficheiro de som digital existente
  • No menu Ficheiro, seleccione "Ficheiro>Importar>" depois um formato de ficheiro do tipo : Wave, Aiff, MP3 ou Macintosh sound resource.
    De seguida seleccione um ficheiro existente no disco duro e clique OK. Um novo documento será criado, com tantas pistas digitais quantos os canais existentes no ficheiro (um para ficheiros monofónicos, dois para ficheiros estéreofonicos).
     
  • Adicionar uma pista a um documento existente.
    • Adicionar o conteúdo de um ficheiro de som digital ao documento :
    • Seleccione "Editar>Pistas de audio digital>Importar". O ficheiro de audio seleccionado no formato Wave, Aiff, Mp3... será lido e adicionado ao documento existente como uma ou duas pistas de audio digital.

    • Adquirir desde uma entrada digital :
    • Clique no ícone gravar na paleta "Ferramentas de gravação" ou seleccione "Editar>Pistas de audio digital>Inicia-para gravação".
      A música começa a tocar e gravação inicia-se. A fonte do som pode ser um microfone (cante ou toque um instrumento acústico) ou um CD audio (inicie a reprodução do CD a partir do painel de controle do seu sistema operativo). Para parar a gravação, clique novamente no ícone.
      Os dados serão adicionados como uma ou duas pistas ao documento existente. Se nenhum documento estiver aberto, será criado um novo.

    • Adquiri desde a janela Karaoke :
    • Start Karaoke, then click on the record icon and sing into the microphone. Your voice is added to the current document as a digital track.
  • Adicionar dados a uma pista de audio digital
    • Crie uma nova pauta : "Pautas>Adicionar Pauta" e altere o tipo para "pista de audio digital" (Pautas>Alterar tipo). De seguida execute o seguinte :

    • Adicionar dados a uma pista de audio digital existente desde um ficheiro de audio digital existente :
    • Clique onde pretende que o som seja inserido na pista de audio digital. Depois seleccione "Editar>Pistas de audio digital>Importar". A leitura dos dados do ficheiro no formato Wave, AIFF, MP3 ... serão adicionados na posição indicada pelo cursor.

    • Adicionar dados a uma pista de audio digital existente desde uma gravação digital:
    • Clique na pista de audio digital onde pretende inserir o som a gravar. Seleccione o modo "Tocar intervalo seleccionado" na paleta "Ferramentas de emissão". Clique no ícone gravar. Clique novamente este ícone para parar a gravação.
  • Converter uma pauta normal numa pista de audio digital
  • Altere o tipo de uma pauta existente para "Pista de audio digital". As notas musicais pertencentes a esta pauta serão convertidas para sons digitais.

      Nota : De momento, não é possível converter uma pista de audio digital para uma pauta normal.

    Validar

    Após a gravação ou importação dos dados digitais, abre-se uma janela. Esta janela mostra-lhe os dados digitais e o tempo. Esta janela também pode ser usada durante a edição da partitura : seleccione uma área em uma ou duas pistas digitais e seleccione "Editar>Pistas de audio digital>Editar selecção".

    São disponibilizados vários modos de edição que podem ser seleccionados através dos ícones por baixo do gráfico relativo ao som digital :

    • Modo Alterar (lápis) : quando activo, você pode alterar as amostras de som clicando na sua exibição gráfica.
    • Modo Ampliar (lente de aumento) : aumenta (clique do rato) ou diminui (Shift + clique do rato) a ampliação do gráfico do som. A barra deslizante ajusta o ínicio da área visível.
    • Modo Seleccionar (laço) : clicando no gráfico de som marcará o intervalo de selecção. O intervalo de selecção é igualmente visualizado à esquerda na forma numérica como números de amostra conjuntamente com a localização em minutos, segundos, centésimos de segundo.
    O menu pop-up “Acções” fornece comandos a ser aplicados ao intervalo de selecção: cortar, colar, apagar, adicionar...

    Área de trabalho :

    A área de trabalho é definida pela localização de inicio e fim.
    Todos os dados dentro da área de trabalho serão aplicados à pista digital aquando da validação, aqueles que estiverem fora da área de trabalho serão ignorados.

    Quando a janela de edição se abre :
    Se você importou um ficheiro de som digital, a área de trabalho está maximizada : ela inclui todos os dados editáveis, ou seja a totalidade dos dados carregados.
    Se você editou uma parte duma pista de audio digital existente, a área de trabalho está maximizada: ela inclui todos os dados editáveis, ou seja o conteúdo do intervalo seleccionado no documento.
    Se você gravou um som, o ponto de inicio da área de trabalho é marcado na primeira porção de dados gravados quando a música começou a ser tocada. Em alguns casos, você pode expandir a área de trabalho para mostrar os dados gravados imediatamente antes da música ter começado a tocar (veja abaixo).

    Os comandos "Enquadrar" e "Mostrar tudo" no menu “Acções” altera os limites da área de trabalho. “Enquadrar” ajusta a área de trabalho para o intervalo de selecção actual, “Mostrar tudo” ajusta a área de trabalho para exibir a amostra completa.

    Se várias pistas de audio digital estiverem incluídas no documento :

    Você pode seleccionar a pista à qual os dados serão aplicados, ou criar uma nova pista. Se os dados forem em estéreo, será aplicado à pista seleccionada juntamente com a seguinte.
    Se você gravou dados de um microfone ou CD audio :
    Quando a janela se abre, os dados gravados são exibidos. Visto que pode existir um atraso entre o inicio da gravação e o inicio da emissão da música, podem existir dados anteriores à primeira localização exibida. Por defeito não são mostrados. Para os ver, seleccione "Acções>Mostrar tudo".
    Se tiver dados em estéreo (Cd audio, importação de ficheiro...) :
    Você pode :
    • Manter os canais esquerdo e direito. Cada canal será aplicado a uma pista diferente. O balanço da pista esquerda será ajustada para a esquerda, o balanço da pista direita será ajustada para a direita.
    • misture os canais esquerdo e direito para obter uma única pista mono.
    • misture os canais esquerdo e direito para remover a voz do cantor. Isto é útil para substituir a voz do cantor pela sua própria voz.
    Se você adiciona dados a uma pista de audio digital existente :
    Você pode seleccionar se quer os dados inseridos na posição actual, adicionados (misturados com) aos dados existentes, ou em substituição dos dados existentes.
    Se definir na pista um ponto protegido :
    Você pode escolher se pretende que os dados tenham em atenção ou não este ponto protegido. (Veja abaixo o capítulo "Editar" para uma explicação dos pontos protegidos)


    Editar

    Indicações gerais
    Todas as operações usuais de edição como cortar, colar, apagar... podem ser usadas com as pistas de audio digital.

    Existem no entanto algumas peculiaridades. Por exemplo, a operação adiciona mistura o conteúdo da área de transferência com o conteúdo do intervalo seleccionado.

    Operações específicas dedicadas às pistas de audio digital : amplificar, amortecer (fade), espelho... podem ser seleccionados através do menu "Pautas>Pistas de audio digital". Estas operações aplicam-se ao intervalo seleccionado. Estas operações estão detalhadas mais abaixo.

    Sugestão : O menu "Editar>Pistas de audio digital" pode ser exibido clicando com o botão-direito do rato numa pista de audio digital (Alt+Clique no Macintosh).
    Pontos protegidos

    Os pontos protegidos são especificos das pistas de audio digital. Eles são projectadas para proteger uma zona de dados de ser movida ou alterada enquanto executa a operação inserir ou apagar : nenhuma operação efectuada antes de um ponto protegido poderá afectar os dados após essa zona.

    Um ponto protegido é representado por uma linha vertical vermelha. Você pode adicionar um ponto protegido em qualquer parte de uma pista de audio digital usando o menu "Editar>Pista de audio digital>Adicionar ponto protegido".
    Quando aplicar dados a uma pista, um ponto de protecção é automaticamente adicionado no ínicio da área modificada.
    Para apagar um ponto protegido, use a ferramenta apagar (relâmpago).

    Acções específicas

    Estas acções executam operações lógicas ou modificam os dados de um intervalo seleccionado.

    Procurar cruzamento zero : Os pontos de inicio e fim do intervalo dos dados seleccionados será ajustado para o cruzamento zero mais próximo. Isto facilita o isolamento de um som num conjunto de dados, e evita "cliques" quando o intervalo de selecção é colado algures na pista (desde que o ponto de inserção seja também um cruzamento-zero).

    Espelho horizontal : Os dados seleccionados são invertidos de cima para baixo (ou seja, a amplitude positiva torna-se negativa e vice-versa).

    Espelho vertical : Os dados seleccionados são invertidos da esquerda para a direita (ou seja, são tocados ao contrário).

    Amplificar : Os dados seleccionados são amplificados de uma determinada percentagem. Um valor abaixo de 100% diminuirá o volume.
    A opção "Normalizar" ajusta o valor da amplitude mais alta da amostra no intervalo seleccionado para a percentagem específicada do valor digital máximo.
    Normalizar para 100% amplifica o som para o valor máximo que é possível sem perda de dados devidos ao corte do sinal digital.

    Amortecer : Amortecimento positivo ou negativo do som. O amortecimento pode ser linear ou logarítmico.

    Zero central : O valor médio dos dados no intervalo seleccionado é ajustado para zero.

    Edição da precisão
    Se desejar editar a precisão de uma parte de uma pista de audio digital (ou uma completa), seleccione a área em que está interessado, e faça "Editar>Pistas de audio digital>Editar selecção". Se seleccionar mais do que uma pista, a edição será feita em estéreo.

    Dicas e sugestões

    Karaoke e regravação :

    É possível iniciar uma gravação na janela de emissão karaoke através de um microfone. Isto permite-lhe gravar uma pista de audio digital contendo somente a sua voz.
    Após ter validado esta pista, você pode reproduzir a composição para ouvir a sua voz adicionada à música. Neste ponto você pode regravar a sua voz e adicioná-la à pista existente. E assim sucessivamente ...

    Problemas de emissão :
    Se, enquanto toca, um alerta o avisa que a sua música não pode ser tocada correctamente, assegure-se de que o disco duro no qual os ficheiros temporários são armazenados não está cheio ou fragmentado. Liberte algum espaço ou faça uma defragmentação se necessário.

    Problemas na remoção da voz cantada :
    Nalguns casos, a voz cantada não pode ser correctamente removida. Isto ocorre normalmente quando importa um ficheiro MP3, e é devido à perda de informação inerente ao formato MP3.
    Também pode ocorrer em músicas em que a voz do cantor não está estéreofonicamente centrada.
     
     



    (c) Myriad 2012