Pagina precedente    Melody Assistant    Pagina seguente 
 

Introduzione
Prodotti
What's new ?
Tutoriale
La notazione musicale
La riproduzione del suono
Introduzione
Regole
Effetti/Espressioni
Aggiustamento microtonale
Intonazioni alternative
Processore effetti
Curve di parametro
Strumenti definiti dall'utente
Tracce Audio Digitali
Jukebox
Karaoke
Dispositivi/procedure
Virtual Singer
FAQ
Licenza d'utilizzo
Assistenza Tecnica
Appendice
Manuale stampabile


New feature : Not yet translated:

 

Tracce Audio Digitali


Le tracce audio digitali consentono di memorizzare i dati audio come valori digitali invece che come simboli musicali.

Una traccia audio digitale funziona come un nastro di registratore che può essere inserito in un documento musicale e su cui si può registrare quel che si vuole per la successiva riproduzione.

Il numero di tracce audio digitali che si possono inserire in un documento è illimitato. In più, è possibile usare insieme nello stesso documento i normali pentagrammi (eseguiti sull'uscita digitale o su quella MIDI) e le tracce audio digitali.

Nota : I processori di effetti digitali possono essere usati anche per le tracce audio digitali...
Usando le tracce audio digitali è possibile per esempio:
  • Aggiungere al documento la vostra voce o una parte strumentale suonata da voi.
  • Registrare una canzone da un CD audio, eliminare la voce del cantante e sostituirla con la vostra.
  • Importare campioni in formati differenti (AIFF, WAV, MP3, SND) e includerli nei vostri brani.
  • Esportare il risultato finale in uno qualsiasi dei formati digitali più comuni e creare i vostri CD audio.
  • eccetera...
Questo capitolo descrive come configurare il vostro computer e le nozioni di base per la manipolazione delle tracce audio digitali.


Indice:

Impostazione della memoria

Impostazione dell'ingresso digitale
Acquisire e importare dati digitali
Validazione
Composizione
Trucchi e suggerimenti


Impostazione della memoria

Melody/Harmony memorizza le tracce audio digitali in formato mono con campionamento a 44,1 kHz e 16 bit (qualità CD).
Una registrazione stereo viene suddivisa su due tracce audio digitali, una per il canale destro e l'altra per il canale sinistro.

Un secondo di registrazione digitale monofonica richiede una quantità di memoria in byte pari a (44100 x 16)/8 = 88200 byte (86 KB).
Questo significa che per memorizzare un secondo di registrazione stereo sono necessari 2 x 88200 = 176400 byte (172 KB) di memoria.
Un brano stereofonico di cinque minuti richiede all'incirca 50 MB di memoria.

Questa elevata quantità di dati viene gestita sull'hard disk come file temporanei o, se preferite e se avete sufficiente memoria, in RAM.

Il modo in cui il programma gestisce le tracce audio digitali può essere impostato con il menù "Configurazione>Impostazioni Generali>Digitale" ("Configuration>Global Setup>Digital").

È importante calibrare questi parametri in modo ottimale per l'hardware del vostro computer, così da accedere ai dati audio digitali nella maniera più veloce.Durante la riesecuzione, Melody/Harmony deve essere in grado di leggere i dati digitali a 172 KB/sec.

Il primo valore da calibrare è la dimensione del buffer di trasferimento. Questa memoria viene usata per emettere il suono in uscita e per le operazioni di copia in fase di composizione. Più il suo valore è elevato, più risulteranno veloci le operazioni di apertura, salvataggio (registrazione), conversione e copia/incolla. Questa memoria fa parte dell'allocazione privata dell'applicazione. Il valore ottimale è compreso tra 512 e 1024 KB.

Potete scegliere la posizione dei file temporanei, usati per memorizzare le tracce e per le operazioni di "annullamento" durante la composizione. Si raccomanda di impostare uno spazio su disco di almeno 100 MB o anche di più se dovete lavorare su file di grosse dimensioni e se volete avere la possibilità di eseguire un numero elevato di "annullamenti" successivi (vedi "Impostazioni generali").
Se avete più di un hard disk o più partizioni, scegliete quella più veloce o quella più vuota. È raccomandabile deframmentare spesso il disco per ottimizzare la velocità di trasferimento (fate riferimento al manuale del vostro computer).

Usare la memoria temporanea ("Use Temporary memory"): selezionando questa opzione, il programma immagazzinerà quanti più dati possibile nella memoria temporanea (RAM) prima di usare l'hard disk. Se avete a disposizione un'elevata quantità di memoria (più di 64 MB), la velocità di elaborazione può aumentare significativamente.

Per aiutarvi a ottimizzare l'impostazione di questi parametri in modo adeguato alle caratteristiche del vostro computer, è possibile usare il bottone "Controlla il mio computer" ("Check my computer") per far partire una procedura di test e visualizzarne i risultati.



Impostazione dell'ingresso digitale

La sorgente per la regitrazione può essere per esempio un CD audio inserito nel lettore CD-ROM drive oppure un microfono collegato al computer.

Nota: La selezione della sorgente per la registrazione (microfono, lettore CD, Aux eccetera) non avviene via Melody-Harmony. Bisogna usare invece la procedura standard tipica del sistema operativo (Mixer Audio su PC Windows oppure pannello di controllo "Suono" su Macintosh)

Il menù "Configurazione>Ingresso digitale" ("Configuration>Digital input configuration") controlla la modalità con cui Melody/Harmony acquisisce i dati dalla sorgente audio selezionata.

Se si è selezionato l'ingresso digitale, durante la registrazione si deve muovere l'indicatore di livello verde sulla sinistra della finestra.

Si può selezionare un ingresso mono oppure stereo. Se si seleziona l'ingresso stereo, verranno create due tracce audio digitali una sotto l'altra: la prima per il canale sinistro, la seconda per quello destro.
Se state registrando da un microfono, la selezione "stereo" non ha effetto.

Su alcuni computer (non su tutti) è possibile regolare il guadagno, cioè il fattore di amplificazione, automatico o manuale, che verrà applicato al segnale audio in ingresso.

Il ritardo in ingresso consente di compensare il tempo di elaborazione del computer: infatti, ci può essere un ritardo tra l'istante in cui arriva il segnale audio e quello in cui il convertitore analogico-digitale restituisce il campione digitale corrispondente.
Melody/Harmony imposta automaticamente un primo valore di ritardo in base ai parametri definiti per l'uscita digitale (vedere la finestra di impostazione dell'uscita digitale). Il valore di ritardo in ingresso viene aggiunto o sottratto a questo valore impostato dal programma.
Per esempio, se registrate la vostra voce su una traccia audio digitale durante l'esecuzione della musica, in fase di riproduzione potrebbe esserci un ritardo di alcuni millisecondi tra la musica e la voce.

C'è un modo semplice per individuare il valore corretto per il ritardo in ingresso:

  1. Create un documento vuoto con una dozzina di battute.
  2. Attivate il metronomo nella palette "Strumenti di riproduzione" ("Play tools").
  3. Iniziate a registrare per due o tre secondi, usando il microfono per registrare direttamente dalle casse del computer anche il suono emesso dal metronomo.
  4. Aggiungete il risultato al vostro documento.
  5. Se il valore del ritardo in ingresso è impostato correttamente, i battiti del metronomo vengono emessi esattamente all'inizio di ogni battuta.
  6. Se i battiti vengono emessi un po' in anticipo (a sinistra della linea di inizio battuta) riprovate aumentando il valore del ritardo in ingresso.
  7. Se i battiti vengono emessi un po' in ritardo (a destra della linea di inizio battuta) riprovate diminuendo il valore del ritardo in ingresso.
Il vostro ingresso digitale adesso è impostato correttamente.
Se modificate i parametri dell'uscita digitale, potrebbe essere necessario reimpostare anche il valore di ritardo in ingresso.



Acquisire e importare dati digitali

Nota: Per registrare una traccia audio digitale, visualizzate la palette "Strumenti di registrazione" ("Recording tools") dal menù "Finestra" ("Windows"). Selezionate quindi il tipo o i tipi di ingresso: digitale e/o Midi. Notate che questi due tipi di ingresso possono essere selezionati contemporaneamente, per esempio per registrare da una tastiera elettronica mentre state cantando al microfono.
Nota per gli utenti diWindows: Prima di iniziare una registrazione digitale, è necessario selezionare un dispositivo di ingresso digitale dal menù "Configurazione>Hardware" ("Configuration>Hardware configuration").
Ci sono diversi modi per inserire una traccia audio digitale in un documento musicale.
  • Importare un file di suono digitale esistente

  • Dal menù Archivio (File) selezionare "Archivio>Importa" ("File>Import>") e poi un formato di file tra: Wave, Aiff, MP3 o Risorsa di suono Macintosh.
    Selezionate quindi un file dal vostro disco rigido e date OK. Verrà creato un nuovo documento con tante tracce digitali quanti sono i canali nel file importato (una traccia per file monofonici, due per file stereofonici).
     
  • Aggiungere una traccia a un documento esistente
    • Aggiungendo al documento il contenuto di un file di suono digitale:
    • Selezionate "Composizione>Traccia audio digitale>Importa" ("Edit>Digital audio track>Import"). Il file seleziontao, nel formato Wave, Aiff, MP3... verrà letto e aggiunto al documento sotto forma di una o due tracce audio digitali.

    • Acquisendola dall'ingresso digitale:
    • Fare click sull'icona di registrazione nella palette "Strumenti di registrazione" ("Record tools") oppure selezionate "Composizione>Traccia audio digitale>Avvio-fine registrazione" ("Edit>Digital audio track>Start-stop recording").
      Il brano comincia a suonare e inizia la registrazione. La sorgente sonora può essere il microfono (per cantare o suonare uno strumento acustico) o un CD audio (avviate la riproduzione del CD dal pannello di controllo del vostro sistema operativo). Per terminare la registrazione, fate click di nuovo sull'icona.
      I dati verranno aggiunti al documento esistente sotto forma di una o due tracce audio digitali. Se non c'è nessun documento aperto, ne verrà creato uno nuovo.

    • Acquisendola dalla finestra di Karaoke:
    • Attivate il Karaoke, fate click sull'icona di registrazione e cantate nel microfono. La vostra voce verrà aggiunta al documento in lavoro sotto forma di traccia digitale.
  • Aggiungere dati a una traccia audio digitale
    • Create un nuovo pentagramma con il menù "Pentagrammi > Aggiungi pentagramma" ("Staves>Add staff") e con il menu" "Pentagrammi>Cambia tipo" ("Staves>Change type") modificatene il tipo in "traccia audio digitale". Eseguite quindi una delle operazioni seguenti:

    • Per aggiungere dati a una traccia audio esistente a partire da un file di suono digitale esistente:
    • Fate click nel punto della traccia audio digitale in cui volete inserire il suono. Selezionate quindi "Composizione>Traccia audio digitale>Importa" ("Edit>Digital audio track>Import"). I dati letti dal file in formato Wave, AIFF, MP3 ... verranno aggiunti nella posizione del cursore.

    • Per aggiungere dati a una traccia audio esistente a partire da una registrazione digitale:
    • Fate click nel punto della traccia audio digitale in cui volete inserire il suono registrato. Nella palette "Strumenti di riproduzione" ("Play tools") selezionate il modo "Riproduci la parte selezionata" e fate click sull'icona di avvio registrazione. Fate click un'altra volta su questa icona per terminare la registrazione.
  • Convertire un normale pentagramma in una traccia audio digitale

  • Modificate il tipo del pentagramma selezionato in "Traccia audio digitale'. Le note musicali appartenenti al pentagramma verranno convertite nei valori di suono digitale corrispondenti.
       
      !!Note to Harmony users: You can convert a digital track in notes using the script "Digital sound>Digital to notes"


    Validazione

    Dopo aver registrato o importato dati digitali si apre una finestra che mostra i dati digitali e la scala dei tempi. Questa finestra si può usare anche in fase di composizione del brano: selezionate una zona su una o due tracce digitali e usate il menù "Composizione>Traccia audio digitale>Modifica selezione" ("Edit>Digital audio track>Edit selection").

    Sono disponibili diverse modalità di composizione che possono essere selezionate con le rispettive icone sotto il grafico del suono digitale:

    • Modifica (icona con la matita): quando questa modalità è attivata è possibile modificare i campioni di suono digitale facendo clock sul grafico del suono.
    • Zoom (icona con la lente): aumenta (click del mouse) o diminuisce (Tasto maiuscole + click del mouse) l'ingrandimento con cui il grafico del suono viene visualizzato. La barra di scorrimento individua l'inizio della zona visualizzata.
    • Selezione (icona con il laccio): la selezione avviene facendo click sul grafico del suono. Sulla sinistra vengono visualizzate anche le coordinate numeriche della parte selezionata sotto forma di numero progressivo del campione e relativo posizionamento temporale in minuti, secondi e centesimi di secondo.
    Il menù a tendina "Azioni" (“Actions”) consente di scegliere il comando da applicare alla selezione: taglia, incolla, cancella, aggiungi ...

    Area di lavoro:

    L'area di lavoro è definita da una posizione di inizio e da una posizione di fine.
    Quando si esegue la validazione, alla traccia digitale verranno applicati tutti i dati all'interno dell'area di lavoro mentre quelli esterni ad essa verranno ignorati.

    All'apertura della finestra di composizione:
    Se avete importato un file di suono digitale, l'area di lavoro è massima e comprende tutti i dati che potete modificare, ossia tutti i dati caricati.
    Se state modificando una parte di una traccia audio digitale esistente, l'area di lavoro è massima e comprende tutti i dati che potete modificare, ossia la parte di documento che avete selezionato.
    Se avete registrato un suono, l'area di lavoro inizia nel primo punto in cui è stato registrato il suono dopo l'avvio della riproduzione della musica. In alcuni casi è possibile estendere l'area di lavoro per visualizzare i dati registrati subito prima dell'avvio della musica (vedere più avanti).

    I comandi "Ritaglia" ("Crop") e "Mostra tutto" ("Show all") del menù "Azioni" (“Actions”) consentono di cambiare i margini dell'area di lavoro. “Ritaglia” imposta l'area di lavoro alla parte selezionata al momento, “Mostra tutto” imposta l'area di lavoro sull'interno campione.

    Se nel documento sono incluse più tracce audio digitali:

    Potete selezionare quale traccia applicare oppure crearne una nuova. Se i dati sono stereofonici, l'operazione si applica in un colpo solo alla traccia selezionata e a quella successiva.
    Se avete registrato dati da un microfono o da un CD audio:
    All'apertura della finestra vengono visualizzati i dati registrati. Dato che ci può essere un ritardo tra il momento in cui inizia la registrazione e il momento in cui inizia effettivamente la riproduzione dei dati, può capitare che ci siano dati registrati prima dell'inizio del brano. Normalmente questi dati non vengono visualizzati. Per vederli, selezionate "Azioni>Mostra tutto" ("Actions>Show all").
    Se avete dati stereo (CD audio, file importati...):
    È possibile:
    • tenere separati i canali destro e sinistro. A ciascun canale verrà assegnata una traccia differente. La traccia corrispondente al canale sinistro è allineata a sinistra, quella corrispondente al canale destro è allineata a destra.
    • combinare i canali destro e sinistro in un'unica traccia mono.
    • combinare i canali destro e sinistro per eliminare la voce del cantante: questo è utile quando volete sostiuire la vostra voce a quella del cantante.
    Se avete aggiunto dati a un a traccia audio digitale esistente:
    Potete scegliere se inserire i dati nel punto corrente, se aggiungerli (combinarli) con i dati esistenti o se usarli in sostituzione ad essi.
    Se sulla traccia destinazione è inserito un punto di protezione:
    Potete selezionare se l'applicazione dei dati rispetta o meno la protezione (per una spiegazione sui punti di protezione, vedi il capitolo "Composizione" seguente).


    Composizione

    Controlli generali
    Sulle tracce audio digitali è possibile eseguire tutte le normali operazioni di composizione come taglia, incolla, cancella eccetera.

    Ci sono però anche alcune operazioni specifiche: per esempio, il comando Aggiungi combina il contenuto della clipboard con l'area di modifica selezionata.

    Il menù "Pentagrammi>Traccia audio digitale" ("Staves>Digital audio track") consente di selezionare altre operazioni specifiche per le tracce audio digitali: amplifica, sfuma, specchia eccetera. Queste operazioni, spiegate nel dettaglio più avanti, si applicano a una selezione di dati.

    Suggerimento: Il menù "Pentagrammi>Traccia audio digitale" ("Staves>Digital audio track") può essere visualizzato facendo click su una traccia audio digitale col pulsante destro del mouse (Alt+Click su Macintosh).
    Punti di protezione

    I punti di protezione sono una specificità delle tracce audio digitali. Si usano per proteggere un'area di dati da spostamenti o cambiamenti quando si eseguono operazioni di inserimento o cancellazione: queste operazioni, se applicate prima di un punto di protezione, non hanno alcun effetto sui dati che si trovano dopo il punto di protezione.

    Un punto di protezione è evidenziato con una linea verticale rossa. È possibile inserire un punto di protezione in qualsiasi parte di una traccia digitale usando il comando "Composizione>Traccia audio digitale>Aggiungi punto di protezione" ("Edit>Digital audio track>Add locking point").
    Quando si applicano dati a una traccia, all'inizio della zona modificata viene inserito automaticamente un punto di protezione.
    Per cancellare un punto di protezione, usare lo strumento di cancellazione (icona con il fulmine).

    Azioni specifiche

    Queste azioni si applicano a una selezione per eseguire operazioni logiche o per modificare i dati.

    Ricerca i passaggi per lo zero ("Seek zero crossing"): Fissa l'inizio e la fine di una selezione nei punti più vicini in cui i dati passano per il valore zero. Questa operazione facilita per esempio l'isolamento di un suono in un gruppo di dati ed elimina potenziali "click" quando la selezione viene incollata in un altra parte della traccia (purché anche al punto di inserimento i dati abbiano valore zero).

    Specchia in orizzontale ("Horizontal mirror"): I dati selezionati vengono invertiti dall'alto in basso (cioè i valori positivi diventano negativi e viceversa).

    Specchia in verticale ("Vertical mirror"): I dati selezionati vengono invertiti da sinistra a destra (cioè vengono suonati all'indietro).

    Amplifica ("Amplify") : I dati selezionati vengono amplificati di una certa percentuale. Un valore percentuale inferiore al 100% provoca un abbassamento del volume.
    L'opzione "Normalizza" ("Normalize") imposta il valore di campione più alto nella parte selezionata in modo che corrisponda a una percentuale specificata del massimo valore digitale.
    Normalizzando al 100% si amplifica il suono al massimo valore possibile senza che si perdano dati a causa della saturazione digitale.

    Sfuma ("Fade"): Il suono viene sfumato in amplificazione (fade in) o in dissolvenza (fade out), in modo lineare oppure logaritmico.

    Centra sullo zero ("Center zero"): Il valor medio dei dati nella parte selezionata viene fissato a zero.

    Composizione specifica
    Se volete modificare in modo specifico una parte o tutta una traccia audio digitale, selezionate l'area che voelte modificare e usate poi il comando "Pentagrammi>Traccia audio digitale>Composizione selezione" I"Staves>Digital audio track>Edit selection"). Se selezionate più di una traccia, la modifica verrà eseguita in modalità stereofonica.

    Trucchi e suggerimenti

    Karaoke e registrazioni ripetute:

    È possibile iniziare una registrazione da microfono anche dalla finestra del karaoke. Questo consente di registrare una traccia audio digitale contenente solo la vostra voce.
    Dopo aver validato questa traccia, potete riascoltare il brano con la vostra voce aggiunta alla musica. A questo punto, potete registrare un'altra volta la vostra voce per aggiungerla alla traccia, per esempio per una seconda parte vocale o per un controcanto, e validare questa nuova traccia. E potete andare avanti così per una terza registrazione, una quarta e così via.

    Problemi in fase di riproduzione:
    Se durante la riproduzione compare l'avviso che la musica non può essere riprodotta correttamente, verificate che il disco rigido su cui sono memorizzati i file temporanei non sia pieno o frammentato. Se necessario, liberate dello spazio o procedete alla deframmentazione.

    Problemi nell'eliminazione della voce del cantante:
    In alcuni casi non è possibile eliminare correttamente la voce del cantante. Questo può accadere specialmente quando di importano file in formato MP3 a causa della perdita di informazione legata a questo particolare tipo di formato.
    Lo stesso problema può capitare in brani stereofonici in cui la voce del cantante non sia registrata centralmente.
     
     



    (c) Myriad