Previous page    Melody Assistant    Next page 
 

Introduction
Products
What's new ?
Tutorial
Notation
Introduction
Music theory
Templates
Positioning
Discontinuous selection
Targets
Tie, slur and beam
Tablatures
Multi-voice staves
Color notation
Gregorian notation
Break symbols
Clef
Key signature
Time signature
Dynamics
Tempo/Speed
Lyrics/Karaoke
Free objects
Text commands
Character fonts
Rendering
Devices
Virtual Singer
FAQ
Software license
Technical support
Appendices
Printable manual


symbol marks changed chapters.

 

Models/Templates

(Templates for a new document)

Introduction

When selecting "File>New", you can select the kind of musical document you want to create from amongst a list of pre-defined templates.
This template list is sorted by family or by theme, to ease your search.

Little icons can appear after the template name. Here is their meaning:

  • A note: the template already contains notes, i.e. one or more pre-written staves are provided with this template.
  • A drummer: the template already contains one or more complete drum tracks.
Templates are in fact regular Harmony-Melody files (.MUS extension) stored in a special folder called Models, located at the application level.

Creating user-defined templates:

It is easy to create user-defined templates for Harmony-Melody. These new templates will appear in the list when selecting "File>New":

  • Create a new musical document you want to be used as a template
  • Select "File>Export>Harmony-Melody Model"
  • Move to the Models folder, and if necessary enter the subfolder you want your new template to be stored in
  • Give a name to your template file
  • A dialog window opens. You can define for your new template:
    • Its complete name, in the different languages known by Harmony-Melody. If you do not know the translation in other languages, leave these fields blank.
    • Its priority, to sort templates belonging to the same sub folder. If you want your template to appear at the top of the list, enter a high value. If you prefer it to appear at the bottom, enter a low value.
    • A check box "Ask for key signature". When this box is checked, a key signature for the piece will be requested every time a new musical document is created from this template. When unchecked, every new musical document uses the key signature defined in the template.

You are invited to view the "How to create a document model (template). " tutorial. ("Windows>Tutorials" menu in the program).

Some hints:

To make your template files easier to use, try to follow these simple rules:

  • Give a comprehensive name to each staff
  • When creating a new staff, a name like "Staff x" is chosen automatically. Rename your staves by using the contextual menu , "Rename" option. Enter for example the name of the instrument playing this staff (Example: Piano 1 or SoloViolin).

  • Check the instrument related to each staff
  • Ensure that the sound used for this staff is correct (contextual menu , "Edit related instrument" option). Avoid for example assigning a violin sound to a staff called "Piano"...

  • Check your printing setup
  • Printing options for your template (margins, indenting, etc.) have to be defined properly. Also check any staff groups (brackets and braces in staff margins).

  • Reduce the number of bars
  • Delete empty bars at the end of a tune if not strictly necessary (Edit>Bar>Delete). If the user of your template wishes to add bars, he just has to insert notes after the last bar.
And do not forget, other users may be interested in your templates. Mention them on http://www.myriad-online.com/bbs or send them to tunes@myriad-online.com if you want them to be included in future versions of the software.
Do not forget to tell us where in  the template tree you want your file to be classified.


(c) Myriad - All rights reserved