previous page                      next page  
Digital Audio Tracks
Digital audio tracks enable you to store audio data as digital sound values rather than as musical symbols.

They are available in Melody Assistant from version 5.0 and in Harmony Assistant from version 7.0.

A digital audio track works like a recording tape that you can include in a musical document and on which you can record whatever you want for subsequent playback.

The number of digital audio tracks in a document is unlimited. Moreover, you can use both regular staves (playing on digital or MIDI output) and digital audio tracks in the same document.
 

Note : 
Digital effect processors can also be applied to digital audio tracks...
 
Digital audio tracks enable you, for example : We will see in this chapter how to configure your computer, and the basics of editing digital audio tracks.


Summary :
Setting up memory

Setting up digital input

Acquiring and importing digital data

Validating

Editing

Hints and tips


Setting up memory

Digital audio tracks are stored by Melody/Harmony in 44 kHz, 16 bits, mono (CD quality) format.
A stereo recording will be split into two digital audio tracks, one for the left channel, the other for the right channel.

This means that for one second of stereo recording, 176400 bytes (172 Kb) will have to be stored.
A five minute tune in stereo will thus use about 50 Mb of memory.

This huge volume of data will be managed as temporary files on your hard disk or, if you wish and have sufficient memory, in RAM.
 

Note for Macintosh users : 
It is not necessary to increase the amount of memory allocated to the application in order to use digital audio tracks. The recommended memory space is still 8Mb, with a minimum of 4 Mb.
On the other hand, you are recommended to select a largish disk cache size (4Mb is adequate) in the "Memory" control panel, and to enable virtual memory.
 
The way the program manages digital audio tracks can be set in "Configuration>Global Setup>Digital".

It is important to adjust these parameters to suit your computer hardware, in order to gain the fastest possible access to digital audio data.When replaying, Melody/Harmony must be able to read the digital data at 172 Kb/sec.

The first value to adjust is the transfer buffer size. This memory is used for sound output and for copy operations when editing. The higher the value, the faster load, save, conversion and cut/paste operations will be. This memory is a part of your application's private memory allocation. An optimal value is from 512 to 1024 Kb.

You can select the temporary files location. Temporary files are used to store tracks, as well as for "undo" operations while editing . A disk space of at least 100 Mb is recommended, even more if you are working on large files with a large number of undo levels (see global setup).
If you have several hard disks or several partitions, select the fastest or the most empty. It is recommended that you defragment this disk quite often to optimize transfer speed. (See your computer manual)

Use Temporary memory : if this option is selected, the program will store as much data as possible in temporary memory (RAM) before using the hard disk. If you own a large amount of memory (more than 64 Mb), it can drastically increase processing speed.

To help you to optimise the settings of these parameters with respect to the specification of your computer, the "Check my computer" button starts a test procedure and displays the result.



Setting up digital input

Recording sources can be, for example, an audio CD in the CD-ROM drive, or a microphone plugged into your computer.
 

Note : 
The recording source (microphone, CD player, Aux, etc...) is not selected in Melody-Harmony, but by using the standard system tools (Audio mixer on the PC, "Sound" control panel on the Macintosh)
 
The "Configuration>Digital input configuration" menu defines the way Melody/Harmony acquires data from the selected audio source.

If a digital input is selected and receives data, the green gauge (on the left of the window) should move.

Input can be made in mono or in stereo. When stereo input is selected, two digital audio tracks will be created one below the other. The first one is  the left channel, the second one the right.
If you are recording from a microphone, there is no point in selecting "stereo".

The gain (only available on some computers) can be adjusted : this is the amplifying factor, automatic or manual, applied to the input audio signal.

The input delay allows you to compensate for your computer's processing time, because there can be a delay between the time that an audio signal is provided to the computer and the time that the corresponding digital data is made available by the analog-digital converter.
Melody/Harmony automatically sets a base delay that is dependent on the digital output parameters you define (see the digital output setup window). The input delay is then added to or subtracted from this base delay.
For example, if you record your voice on a digital audio track while music is playing, a delay of a few milliseconds between the recorded voice and music can occur when the item is replayed.

Here is a simple method to get the right value for the input delay :

  1. Make an empty document of about twelve bars.
  2. Enable the metronome in the "Play tools" palette.
  3. Start recording and directly record, with a microphone, the metronome sound emitted by your computer loudspeakers for two or three seconds.
  4. Add the result to your document.
  5. If your input delay is correctly set, the metronome clicks will occur precisely at the beginning of each bar.
  6. If clicks fall a little bit early (on the left of the bar line) increase the input delay and retry.
  7. If clicks fall a little bit late (on the right of the bar line) decrease the input delay and retry.
Your digital input is now set up.
If you change the digital output parameters, it may be necessary to perform this setup again.



Acquiring and importing digital data
 
Note : 
To record a digital audio track, display the "Recording tools" palette ("Windows" menu). Then select the input type(s) : digital and/or Midi. Please note that these two kinds of input can be selected at the same time, enabling you to record what you are playing on an electronic keyboard while singing into a microphone. 
 
Note to Windows users: 
Before starting a digital recording, you must select a digital input device in "Configuration>Hardware configuration".
 
There are several ways to include a digital audio track in a musical document.
  • Importing an existing digital sound file

  • From the File menu, select "File>Import>" then a file format from : Wave, Aiff, MP3 or Macintosh sound resource.
    Next select an existing file on your hard disk and OK. A new document will be created, with as many digital tracks as there are channels in the file (one for a monaural file, two for a stereophonic file).
     
  • Adding a track to an existing document.
  • Adding data to a digital audio track
  • Converting a regular staff into a digital audio track

  • Change the type of an existing staff to "Digital audio track". The musical notes belonging to this staff will be converted to their digital sound values.


    Validating

    After each digital data recording or import, a window opens. This displays the digital data and timing. This window can also be used during score editing : select an area on one or two digital tracks and select "Edit>Digital audio track>Edit selection".

    Several editing modes are provided and can be selected by the icons below the digital sound graph :

    The “Actions” pop-up menu provides commands to be applied to the selection range : cut, paste, erase, add ...

    Working area :

    The working area is defined by a starting and an ending location.
    All data within the working area will be applied to the digital track when validating, those outside the working area will be ignored.

    When the editing window opens :
    If you imported a digital sound file, the working area is maximal : it includes all the data you may edit, i.e. the whole of the loaded data.
    If you edited a part of an existing digital audio track, the working area is maximal : it includes all the data you may edit, i.e. the content of the selected range of the document.
    If you recorded a sound, the working area starting point is set at the first piece of data recorded when the music started playing. In some cases, you can expand the working area to show data recorded just before the music started (see below).

    The commands "Crop" and "Show all" in the “Actions” menu change working area boundaries. “Crop” sets the working area to the current selection range, “Show all” sets the working area to the whole sample.

    If several digital audio tracks are included in the document :

    You can select which existing track data will be applied to, or create a new track. If the data is in stereo, it will be applied to the selected track together with the next one.
    If you recorded data from a microphone or an audio CD :
    When the window opens, the recorded data is displayed. Since there can be a delay between the start of recording and the start of tune playing, data can exist before the first displayed location. By default this is not shown. To view it, select "Actions>Show all".
    If you have stereo data (audio CD, file import...) :
    You can :
    If you add data to an existing digital audio track :
    You can select whether the data will be inserted at the current location, added to (mixed with) the existing data,  or used to replace it.
    If a locking point is set on the target track :
    You can select whether the application of data observes this locking point or not. (See the "Editing" chapter below for an explanation of locking points)


    Editing
    General points
    All the usual editing operations like cut, paste, erase... can be used on digital audio tracks.

    There are however some peculiarities. For instance, the  add operation mixes the clipboard content with the current selection range.

    Specific operations dedicated to digital audio tracks : amplify, fade, mirror... can be selected from "Staves>Digital audio track". These operations apply to the current selection range. They are detailed below.
     

    Tip : 
    The "Staves>Digital audio track" menu can be displayed by right-clicking on a digital audio track (Alt+Click on Macintosh).
     
    Locking points

    Locking points are specific to digital audio tracks. They are designed to protect an area of data from being moved or altered while performing insert or delete operations : no operation performed before a locking point can affect data located after it.

    A locking point is shown by a red vertical line. You can add a locking point anywere on a digital audio track by using "Edit>Digital audio track>Add locking point".
    When applying data to a track, a locking point is automattically added to the start of the modified area.
    To delete a locking point, use the delete tool (lightning bolt).

    Specific actions

    These actions perform logical operations or modify data within the selection range.

    Seek zero crossing : The starting and ending points of the selection range will be set to the nearest zero crossings of data. This facilitates the isolation of a sound in a set of data, and avoids "clicks" when the selection range is pasted elsewhere in the track (provided the insertion point is also a zero-crossing).

    Horizontal mirror : The selected data is inverted top to bottom (i.e. positive amplitude becomes negative and vice-versa).

    Vertical mirror : The selected data is reversed left to right (i.e. is played backwards in time).

    Amplify : The selected data is amplified by the specified percentage. A ratio below 100% will decrease volume.
    The "Normalize" option sets the highest sample amplitude value in the selection range to the specified percentage of the maximum digital value.
    Normalize to 100% amplifies the sound to the maximum value that is possible without the onset of data loss due to digital clipping.

    Fade : Sound fade in or fade out. The fade can be linear or logarithmic.

    Center zero : The average value of data in the selection range is set to zero.

    Precision editing
    If you wish to precision edit part of a digital audio track (or a complete one) , select the area you are interested in, then "Staves>Digital audio track>Edit selection". If you select more than one track, editing will be performed in stereo.

    Hints and tips
    Karaoke and re-recording :

    It is possible to start a microphone recording from the karaoke play window.This enables you to record a digital audio track  containing just your voice.
    After having validated this track, you can replay the tune to hear your voice added to the music.At this point you can record your voice again and add it to the existing track. And so on ...

    Playing problems :

    If, when playing, an alert tells you that the music cannot be played properly, ensure that the hard disk on which temporary files are stored is not full or fragmented. Free up some space or start a defragment operation if necessary.

    Singer's voice removal problems :

    In some cases, the singer's voice cannot be be removed properly. This is particularly likely to occur when importing an MP3 file, and is due to the information loss inherent in the  MP3 format.
    It can also occur in  pieces where the singer's voice is not stereophonically centered.
     
     


      previous page                      next page