página anterior    Harmony Assistant    página siguiente 
 

Introducción
Productos
¿Algo nuevo?
Tutoriales
Notación
Introducción
Solfeo
Modelos
Modo página
Modo grabado
Positionning
selección discontinua
Views
Targets
Ligado y enganche
tablaturas
Pentagramas fusionados
Color notation
Notación gregoriana
Repeticiones
Clave
Armura
Signatura tiempo
Matices
Movimiento
Letra / karaoke
Objetos libres
Textos especiales
Fuentes de símbolos
Juegos de símbolos
Escucha
Devices/scripting
Virtual Singer
Preguntas / Repuestas
Licencía de utilización
Asistencia técnica
Appendices
Manual imprimible


Nuevo capitulo: En inglés:

 

Views

Introduction

A view is a different way of displaying a same document. This display can be stored in the document itself, and saved with it.
The user can switch quickly from one view to another, add or delete views. There is no limit for the number of views that can be related to a document.

For instance, by using views, an orchestra score can be easily created. This score file contains a general view, displaying all the performers' staves, then one view for each kind of instrument.
Of course, this can be printed.

Note : Views related to a document need page mode: they are therefore available only in Harmony Assistant.
If, with Melody Assistant, you load a score that contains views, only the general view will be available. A message will warn the user about it.

When defining a view, you choose the settings that are specific to this view, and those that will be inherited directly from the general view.

If a setting is specific to a view, changing it in the general view (or in any other view) won't affect this view.
If a setting is not specific to a view, changing it in the general view will affect this view, and vice versa.

The name of the current view is displayed in the window title, after the file name. When a view-specific setting is edited, the name of the view is displayed in the edit box title. If no view name is displayed, then it means you are currently working on the general view, and that all the changes will affect both the general view and all the views that inherit this setting)

Settings

Music symbols as notes, dynamics, clef changes, keys, time signatures, etc, are common to all views. For instance, if you change a note pitch, it will affect all views.

A view is primarily defined by its name, the staves it contains, and by its  properties.

Staves: Each staff in the document can be displayed or not in a view. It is the basis of the notion of view. A view can contain as many staves as you wish. A same staff can only be displayed once in each view.

Tempo display: Tempo marks in the score will be displayed on the first staff of this view

Global dynamic display: Global dynamics (that apply to all staves in a score) will be displayed on the first staff of this view.

Global text display: Text objects related to staves will be displayed on the first staff of this view.

Title, Composer, Remarks: A view can set its own header ("File > Title, Composer, Remarks" menu option). This is especially useful if the printing options ask for displaying this information at the beginning of the document.

Page settings: In page mode, the exact preview of what will be printed is displayed on screen. A view can define its own page settings ("File > Printing options" menu item). For instance, the printing scale, group captions, margins, page header and footer, etc, can vary from one view to another

Engraver mode: Each view can define its own engraver mode settings ("Score > Engraver mode setup" menu item). Note spacing  rules can then be different from one view to another.

Score appearance settings: Each view can define its own score general appearance ("Score >Display setup" menu item): line thickness, accidental spacing, tie appearance, etc.

Fine positions: Each view can define its own fine positions: staff spacing, group name position, etc.

Staff appearance settings: Each view can define its own staff appearance settings ("Staff > Staff display mode" menu item): symbol size, default colors, etc. Of course, it only apply to staves that are displayed in this view

Transposed score: Each view can define whether the score is displayed transposed or not ("Options > Display transposed score" menu item).

Group symbols: Each view can define its own appearance and position for bracket and braces that represent staff groups.


"Views" menu

The view menu enable to edit (thus, create) views, to switch between views or to select directly a view to work on it.

Creating and editing views

To create and edit view, please use the "Views > Edit" menu item. The window that opens is split into three parts: the document staff list, the document view list, and the view staff list.

Document staff list

Staff names are displayed in the order of their presence in the document. Because a same staff can only be included once in each view, staves are displayed in grey when already present in the view.

Select a staff and click the "Add to view" button to add this staff to the current view, or double-click the staff to add. You can select several staves through Shift+Click to add several staves in a row

The Create view from staves button will wipe out the view list then create one view for each staff.
The Create view from groups button will wipe out the view list then create one view for each staff group.

Document view list

When a view is added to the document, it appears here. The view order can be changed: click a view name and drag it in the list to change its position.

Several buttons enable to apply actions to the view list: create a new view, change the view settings, duplicate the selected view, delete the selected view, delete all views, change the printing options of the selected view.

To copy the settings or the printing options to all view, right-click a view and select the action to be applied in the contextual menu.

You can select several views through Shift+Click then apply actions to all the view by right-clicking an item in the list.

View staff list

It's the list of staves in the selected view. A button enables to delete the selected staff from the view. This doesn't delete this staff from the document.

Text objects in views

By default, text objects related to staves are displayed in all view that contain this staff.

If the staff that contain the text object is not present in the view, and the view define that global text objects are also displayed, then the text is displayed on the next visible staff of this view

When editing a text object, a pop-up menu enable to relate this text to a given view, or all the views except the general view.


Free objects in views

When editing a freeobject, a pop-up menu enable to relate object to a given view, or all the views except the general view.

Music performance

In the "Play tools" palette, you can select whether you wish to play the view content only, or all the staves.

Printing

When printing a score, the current view will be printed.
If you wish to print all the views, select "File > Print > All views".
Please note that the view order (thus the printing order) can be changed from the view creation and editing window

Tips

To switch quickly between view, a palette is available in "Scripts > Notation > Select View"





(c) Myriad 2013 - Todos los derechos reservados