Introduction


You now own one of the most powerful and user-friendly tools for computer-assisted music-making. This software will quickly become an essential aid to your inspiration.

The software includes its own on-line documentation. All objects, menu options and dialog boxes are self-documented. When you point to any object with the cursor, an explanation is displayed in the help window. The document you are reading describes everything that is not described in the help window.
 
You'll find here the basic concepts of music theory, a set of questions and answers, a concrete example to use with the software and some thematic chapters.

In addition, more than 100 interactive video tutorials, available from the "Windows>Tutorials" menu, explain the basic and advanced features. You can search the tutorial list for a topic by typing its name.  For example, "staves" will show tutorials that deal with staves.  The tab key will jump to the next tutorial in the list.

You are invited to view the "How to view video tutorials." video tutorial. ("Windows>Tutorials" menu in the program).

The document you are reading right now covers topics not directly related to objects in the program. You will find here basic ideas of music notation, a step-by-step concrete example, tips to use the software better, a set of frequently asked questions, and thematic chapters.

You are invited to view the "How to use the integrated help system: help line, search the manual by keywords. " video tutorial. ("Windows>Tutorials" menu option in the program.)

Lastly, in Harmony Assistant, extra features enabled by the MyrScript scripts are described in the "Scripts>About scripts..." menu option

Important: At the end of this document is the Software license chapter. You must read it before using the software.


.

Products


Here are short descriptions of all our music-related products.

Melody Assistant (shareware - US $37 / Europe: 30 €)

Enables you to enter, play and print musical scores with astonishing ease. But its capabilities are much greater: a digital sound database is integrated so you can hear your tunes with high-quality sounds, even if you do not own professional hardware or an external MIDI keyboard.
With this technology, you will also be able to record your own sounds and use them as instruments in your tunes.
An extended "Gold" sound database, even more complete, can be ordered.
Guitar, Bass and Harmonica players will also be happy with Melody Assistant, since it is possible to calculate tablatures and chord diagrams automatically from a tune.

Available on Mac OS, Windows and Linux.

Question: What is meant by "shareware"?
You can try Melody Assistant free. If the program meets your requirements, you can then order a personal registration number (for US $25 or 20 euros if you live in Europe) and access the software's most advanced features. In this documentation, the options available only to registered users are clearly indicated.


Harmony Assistant (commercial product - US $85 / Europe: 70 €)

Harmony Assistant can be considered Melody's "big brother". All the Melody Assistant features are, of course, included, but a wide range of new tools are added: full-page editing, engraver mode, chord grid calculation, automatic generation of harmony accompaniments or rhythm patterns, redefined or user-defined music styles, integrated scripting language, etc. Again, features only available in Harmony Assistant will be clearly indicated in this documentation.

Available on Mac OS, Windows and Linux.

Question: Is Harmony Assistant "shareware"?
No. It is a commercial product, which can be ordered for US $85, or 70 euros if you live in Europe. You can test the amazing harmonizing capabilities of Harmony Assistant by downloading a trial version. With the trial version, you will only have a reduced sound database, and you will not be able to save or print your musical documents. You will, however, be able to take a look at all features to ensure that they meet your requirements.

PDFtoMusic (US $49 / Europe: 40 €) and PDFtoMusic Pro (US $199/Europe: 199 €)

You often download score files in PDF format from the Internet, and you'd wish to hear them?

You'd want to hear the Soprano part from the score your choir master owns on his computer?

PDFtoMusic is designed for you. Open a PDF document, and after a few seconds, you just have to click a button to hear the score playing, and even the lyrics be sung! You can then save it as an editable Melody/Harmony Assistant file, a MIDI file or, with PDFtoMusic Pro, as a MusicXML file that can be opened by most of the other professional score editors.

PDFtoMusic gives you full access at last to the giant PDF music score collection available on the Internet.

Please note that PDFtoMusic / PDFtoMusic Pro only processes PDF files that have been generated by a score editor. It doesn't process scanned music sheets.

Available on Mac OS and Windows.

OMeR (shareware - US $25 / Europe: 20 €)


OMeR converts a printed musical score into a music file you can hear, modify and print with Melody Assistant or Harmony Assistant.
If you often transcribe printed scores to Melody Assistant or Harmony Assistant, and you own a scanner, OMeR will greatly ease your task.
OMeR will drive your scanner, collect one or several pages and analyze them to generate a musical document usable directly in Melody or Harmony.

Available on Mac OS and Windows.

Virtual Singer (shareware - US $25 / Europe: 20 €)

Plug-in for Melody or Harmony. With Virtual Singer your computer will sing lyrics in different languages.

Available on Mac OS, Windows and Linux.

GOLD Sound Base -  (CD-ROM: US $37 / Europe: 30 € , Download: US $25 / Europe: 20 €)

The Gold Sound Database is a set of high-quality digital sounds, designed to be used in the Myriad software programs. The Gold Sound Database includes all the sounds of the General Midi 2 specification, as well as many additional sounds.
Thus, the Gold Sound Database improves not only the quality of tunes the software plays, but also the quality of WAV, AIFF, Ogg Vorbis or MP3 files the software exports.

Available on Mac OS, Windows and Linux.


Tutorial


We are now going to look together at the software step by step. You are advised to follow this chapter carefully, and carry out each instruction.

A. Launching the software

When you launch the software, you are asked to select a language. Choose "English".

With Melody Assistant, you can print a registration form, i.e. order one of our products, or enter your personal registration number (received after you purchased the software), or continue. Choose "Continue".

With Harmony Assistant, in evaluation mode, choose "Continue".

Note: These choices will not have to be made with a registered version of Melody Assistant, or a complete version of Harmony Assistant.

This brings you to the software's main screen.

At the top of the screen is a menu bar containing the main options. Scattered on the screen are a number of floating palettes which allow quick access to most of the tools.
You can change each floating palette's location by dragging its title.

Note: the floating palettes’ positions are memorized each time you quit the software. They will be recalled next time you launch it.

Click on its little gray square to close a floating palette. You can make it appear again by selecting it in the "Windows" menu.

Tip: Command (Ctrl) key + click on a palette's title to change its orientation (vertical or horizontal). The help window can be resized. To do this, drag the little black rectangle on the window's bottom-right corner.

You are invited to view the "How to setup palettes to avoid overlapping with document windows." and "How to create an user palette. " video tutorials. ("Windows>Tutorials" menu in the program).

Finally, the main window shows a sample tune, automatically loaded when the software is started.

To help you learn all the software tools and options, a help window (yellow rectangle) continuously displays explanations of each object as the cursor runs over them.


Tip: The help window also gives the meaning of menu titles and options. So place it where it can be seen even when a menu is open (for example, at the bottom of your screen).

B. Listening to a tune

Find the tune playing tools floating palette:

Note:  Since the icons' appearance can be easily changed by you (see the General Setup), pictures shown here may be slightly different from what you see on your screen.
You are invited to view the "Using another icon set." video tutorial. ("Windows>Tutorials" menu in the program).



Start playing a tune by clicking:


The sample tune is now played. You can stop it by clicking:


If you do not stop it, it will stop by itself at the end of the tune.
 
Tip: The space bar also starts and stops a tune.

Creating a new tune

New Document


First of all, close the sample tune window.
Create a new document, with the File>New menu option.

Select the model "Very simple (One staff only)" in the list.

We will add a bass clef to this model. Click on "Change orchestra".

Your new document window is now ready, with an empty score. In "Simple staves" select "Simple staff (Bass clef)".

Click on ">>Add>>" then "Ok". The new staff was added.

Click on "Create" a new blank document was created. It is displayed on a new window and ready to receive your changes.

You are invited to view the "How to create a document model (template)." video tutorial. ("Windows>Tutorials" menu in the program).

Tip: A long floating palette ("Actions" palette) contains shortcuts to the most common menu options.

Creating a new tune

Entering a melody


You are now going to place notes on the staff to create a melody.

You are invited to view the "Score input. Adding notes, rests, staff. Changing key and time signature. Selecting an instrument. Changing tempo. Adding bar line. Automatic beaming setup." video tutorial. ("Windows>Tutorials" menu in the program).
 
To do this, select the note lengths in the Notes floating palette and place them on the upper staff (treble) one after the other.
Select an eighth note and place it on the E line (bottom line) of the staff.
 
Tip: If you have trouble inserting notes where you want them, you can increase the display scale. There are several ways to do this:
  • Select the Windows>Scale menu option and choose a scale factor, or
  • Click on the magnifying glass in the editing mode floating palette and click on the score, or
  • Hold the mouse button down while clicking on the magnifying glass and move the cursor up.
If you use the magnifying glass tool, do not forget to return to note insertion mode (click the icon with a pencil and a note).

Place another E eighth note just to the right of the previous one. The two notes are automatically beamed together.

Now select a quarter note in the floating palette.
Drop it, again on the E line, to the right of the first two notes.

You now have a group of three notes in the first bar: two eighths and a quarter on the E line.

Drop a new group of three notes, identical to the first one. The first bar is full.
In the second bar, drop an E eighth note, then a G eighth note (second line from the bottom).
You now have to place a dotted eighth note: leave the eighth note duration selected in the floating palette, and click on the dot in the accidental palette (palette with sharp, flat and natural signs).

Drop the dotted eighth note in the second bar, after the notes already placed, on the bass C leger line (one line below the bottom line of the staff).

Click again on the dot in the floating palette to deselect it. This returns you to non-dotted note duration.
Continue to drop successive notes:
In the second bar:

Sixteenth note D (between C and E lines)
Half-note E
Third bar Eighth note F (between the two bottom lines of the staff)
Eighth note F
Dotted eighth note F
Sixteenth note F (Don't forget to deselect the dot mode)
Eighth note F
Eighth note E (bottom line)
Eighth note E
Eighth  note E
Fourth bar Eighth note E
Eighth note D
Eighth note D
Eighth note E
Quarter note D
Quarter note G (second line from the bottom)
The first four bars of the top staff are now complete.
Important:
If you make a mistake when dropping a note, select the lightning icon in the Edit floating palette, click on the incorrect note to delete it, and come back to insert mode (icon with a pencil and a note).
You can also use the Edit>Undo menu option to undo the last performed operation.
Alternatively you can select the lasso icon and physically move a note by clicking on it, holding down the mouse button, repositioning the note and releasing the mouse button.

Tip: In insert mode, you can quickly change to delete mode by holding down the Command key (Ctrl on PC), or to select mode by holding down the Option (Alt) key.

Play
your score . You will hear the "Jingle Bells" theme with a piano sound.
Save your document by selecting File>Save. Name it JBell.mus
 
Hint: Save your work frequently with File>Save
(Caution: Document saving is not available with the evaluation version of Harmony Assistant.)

Creating a new tune

Changing the staff instrument


We are now going to give a music box sound to the melody.

To the left of the staff, little icons can be used to perform various actions on it.

Point to them with the cursor and read the explanations in the help window.
 
 
Hint: If you cannot see these icons, then you are probably in page mode, and "display handles" mode is off. Switch to scroll mode or activate the control handles ("Score" menu).


Click on the little "instrument editing" icon  .
The instrument selection window opens. In the top-left corner is the current instrument name: here "Piano". Select this name and replace it with "Music box".

In the bottom of the window are two lists for selecting the instrument sound. The left one contains the sound set (sounds are organized by theme). Click on "Chromatic percussion".
In the right list are the names of sounds in this group. Select "Music Box".

Note: These names follow the General MIDI standard.

To hear this sound before selecting it for good, click on "Try" and keep the mouse button down. By moving the cursor up and down, you can hear this sound at different pitches.

Hint: have fun browsing the lists and trying the available sounds. Then come back to "Chromatic percussion" - "Music box".

Confirm your choices by clicking OK.

Play your melody again 

Creating a new tune

Changing the name of a staff and resizing it

Changing the name of a staff


Above the treble clef is the staff name. By default, it has been set to "Piano". We are going to change it to "Main".
Find the little black triangle above the icons in the staff's left margin  .
Click on it, and the staff configuration menu opens. With this menu, you can access all the staff configuration options.
 
Note: Some of these actions, like instrument selection, can be accessed faster by clicking on the icons below the black triangle.

In the staff menu, select "Rename" and type in the new staff name: "Main".
Confirm your actions: the new name is displayed above the treble clef.

Resizing the staff

We are now going to resize the screen area reserved for the top staff. Click on the horizontal red line below the staff configuration icons in the staff margin and drag the cursor down.
The space allotted to the first staff is enlarged, and the second staff (bass clef) is shifted down. When you think that the allocated space is wide enough, release the mouse button (try, however, to have both staves visible on screen).

You will have noticed that the treble staff remained at the top of its area. To center it, drag the lower red triangle down. The staff is then repositioned within its enlarged space.

Creating a new tune

Entering chords on the second staff


On the bass (second) staff, we are going to place chords to accompany your melody.
To help you place notes, if you are not very familiar with musical theory, here is the list of notes you are going to use, along with their position on the staff:

            __ treble G __
               treble F
            __ E __
               D
            __ C __
               B
______________ A ________________ Topmost line
               G
______________ F  ________________

___________________________________

___________________________________

___________________________________ Bottom line

In the first bar, we're going to begin with a  C major chord in its 2nd inversion, that is to say: G, C and E.

Select a half-note  and drop a G into the first bar of the bass staff (see above to get the position of G on the staff).
Then drop a C above this note. To help you, when moving the mouse, the note to be dropped must show a + symbol which indicates that this note will be dropped in the same column as an existing note.
The C appears in the same column as the G: these two notes will be played at the same time. Then place an E (two leger lines above the topmost line of the staff), also in the same chord. Your chord is complete.

To the right of this chord, place the same chord again, still with half-notes. The first bar is complete:
.

Tip: Rather than entering the same three notes again, you could use the copy/paste option:
  • Choose the Selection (lasso) tool in the floating edit palette.
  • Click to the left of the chord already placed on the staff and keep the button pressed down.
  • Drag the mouse to the right so that the selection encompasses the chord.
  • Release the mouse button
  • Select Edit>Copy (Command-C)
  • Click in the place you want this chord to be duplicated (to the right of the first one)
  • Select Edit>Paste (Command-V)

  • Do not forget to return to note insertion mode (pencil and note icon).

In the second bar, place the same chord again.
 
Tip: If you used the copy and paste options to insert the second chord, you can simply select "Paste" again.

Then place an A minor chord, made of half-notes A, C and E as above.
The second bar is complete.

In the third bar, place an F major chord, made of A, C (as above) and F.
Next place a C major chord, identical to those in the first bar.
The third bar is complete.

In the fourth and last bar, place a D minor chord, made of A, D and F.
Then select a quarter note duration .

Place a G chord (G-B-D) and an inverted G chord (B-D-treble G)

If you did not make a mistake, you should have something like this:



Play the tune 

Creating a new tune

Creating a new instrument


Now we are going to create a new instrument to change the sound of this staff.
As with the previous staff, click on the icon   in the left margin to edit the related instrument.

At present, the chosen instrument is called Bass. To the right of the instrument name, click on the downward-pointing gray arrow to open a menu.
The list of instruments already created opens.
Select "New instrument".
Give a name to your new instrument. Call it "String Ensemble".
In the sound lists, select "Ensemble" and "Slow strings"
Confirm this window with OK. You have just created a new instrument with a new sound.

This instrument will be used by the bass staff.

Play your tune to try the new instrument 

Creating a new tune

Creating a user-defined sound


We are now going to change the treble staff instrument to make it use a sound that you have recorded.
Click on the instrument edit icon for the first staff .

Switching to user mode

We are now interested in creating our own sound for an instrument.
To do this, you must first switch the instrument to "user" mode by clicking on the "Std" button in the top left corner of the window. The "Std" button changes to show that you are now working with a "User" sound.
A graph is now displayed in the lower part of the editing window. This graph shows the digital data that the 'Music box' sound is made of.

Preparing for recording

Using your system control panel, set up the sound recording (from a microphone or a CD). If possible, first try making a recording using another software program to ensure that everything is working properly.
If you use an audio CD, find a tune with a note played solo and for a long time.
If you use the microphone, be ready to sing a note or play a single note on an acoustic instrument.

Recording

Click the  icon to access the digital recording window.
On the right, the VU-meter allows you to adjust the input level.
When you are ready, click  to start recording (5 seconds).
When it is completed, click OK (and if necessary stop your audio CD).
 
Hint: Play an accurately tuned note, a C if possible.
 

Listening to the recorded sound

After recording, return to the sound definition window, and you can "see" what you recorded. Straight horizontal lines correspond to the moments during which nothing was played.
To hear the sound you recorded, click
If you are not satisfied, you can record the sound again.

Isolating the sound

You must now isolate the interesting part of the recorded sound. To do this, click and drag from the beginning to the end of the section you want to keep. The selected area appears on a colored background.

Tip: Use the zoom slider to enlarge the sound display scale.
 
Click  to listen to your selection.
When you are satisfied (you must only hear one note, with no preceding silence), open the Action pop-up menu, and select 'Crop'.

Entering the input note

To put the instrument you just created in tune with the others used in your music, you must confirm the recorded note.
Enter the name of the input note in the "Input note" field.
 
Tip: When you click "Try" and hold the mouse button down, the note heard must be a C.

Confirming and listening

Confirm your changes with OK. This returns you to your musical document.
You can hear your new user instrument by playing the tune .
 
Tips You can also import recorded sound files like WAV, SF2, etc. Select "Import" in the pop up menu "Actions".

SF2 (also called SoundFont) are sound files including a lot of sound samples designed for hardware MIDI synthesizers.
When opening a SF2 file, a dialog box lets you choose one or more samples for the current instrument.

For more information about how to create and manage user digital sounds, read the Predefined user instruments chapter.

Creating a new tune

Placing graphics and text


To comment or ornament your score, you can place colored text and graphics anywhere you want on the staves.
Click on the "Txt" icon in the floating palette to switch to text insert mode.

Click where you want the text to be inserted. A window opens and you can type in the desired text and select its color, font, size and style.
For example, enter "Jingle Bells" and select the Times (or Times New Roman) font with a size of 32, bold, red.

Tip: The "Ab" icon (at the bottom) allow text to be displayed over the other elements without erasing them.

Confirm. The text appears on your score, surrounded by a red frame.

You can drag the text frame, resize it (by dragging its bottom-right corner) or edit it again (double-click).

To place a graphic, the operation is more or less the same. Select "Graphics" (the icon with a square, circle and triangle) and click where you want your graphic to be inserted.
In the window, select the shape to be inserted by using the horizontal scroll bar (for example, the ribbon) as well as its color (green) and confirm.
The chosen graphic appears at the desired place.

Tip: You can also place graphics created in a drawing program by clicking "Other" in the graphics selection box and choosing a BMP file (or PICT on Macintosh).

Creating a new tune

Entering comments and printing


You can put comments on the first page of a printed score. To edit them, select File>Comment.
Enter the tune title (Jingle Bells), the composer (James Pierpont, 1857) and the remarks (for example, "Christmas song") and confirm. 
 
Tip: At the bottom of this window, you can read information about the file, including the time spent on this tune. Interesting, but also depressing at times!

Now select File>Print>Score

A print preview appears and you can see what the printed page will look like.
By clicking the "Options" button, you can then choose what you want to be printed. Check Print infos on first page and deselect the other options. Finally, on the list at the bottom, ensure that your two staves (Main and Bass) are marked with a little printer icon.
OK this box and select your usual printer settings.
Then click on "Print page".


Note: It is only possible to print one page with the trial version of Harmony Assistant.

With an unregistered version of Melody Assistant, you can print, but a message will remind you to register for a modest sum if you enjoy this software.
Of course, this message will disappear as soon as your copy is registered.

Creating a new tune

Changing bar widths


To adjust the number of bars appearing at the same time on screen or on a printed page, you can  fix the bar widths either individually or globally. Doing so will move notes closer together or further apart.
 
Note: You must not confuse this feature with zooming (or scaling), which enlarges or reduces all symbols to make them more readable on screen: printing is not affected by the zoom setting, and notes that appear too close or overlapped keep their relative distance.


Individual setting
:
At the top of your main window the ruler (gray bar) indicates bar numbers. When you point to the line in the ruler separating two bars, the cursor changes. By dragging this line, you can change the width of the individual bar.

Global setting:
Select more than one measure by clicking on the ruler and change the size of one measure in the selection. This size will be applied to all the selected bars.
 

Tip: Bars are displayed on screen side by side, making a continuous "ribbon" from the first to the last. As the printed page width is not infinite, they will be printed in strips one below another. On screen, a vertical yellow line shows where the staff is cut into strips while printing.


Creating an automatic accompaniment


At the top of the document window, between the ruler with its bar numbers and the staves, two areas can be used to define rhythm patterns and automatic accompaniments.These are called the rhythm array (green area) and the accompaniment array (gray area).
 
You are invited to view the "Creating automatic accompaniments and rhythms from a melody with Harmony Assistant " video tutorial. ("Windows>Tutorials" menu in the program).

Note: These areas are only displayed when they are enabled in the Options menu.

Above these two areas, the chord grid shows the chords calculated for each bar.

Click in the accompaniment array cell above the first bar.
The accompaniment definition window opens. Click on "New" and give a name to this new accompaniment (for example "Bass line"). Then click the "Edit" button.

This brings up a window with tabs for defining the details of the accompaniment.

Open the "Instrument" tab and select the pre-defined "Bass" instrument.
 

Note: Click on "Edit" to define a new instrument or to modify an existing one, just as in "regular" staves.

Then open the "Notes" tab.

Here you can define the sequence or the chord type to be followed by the accompaniment while the tune is playing.
Select "based on the model" and select the "Blues > Classic > Bass 1" pattern from the left-hand list. Click "OK" for this window, and for the accompaniment window.
Your accompaniment is created.

Note: Accompaniments are played only when the "Accompaniments active" icon (tune playing floating palette) is selected.

You will notice that the accompaniment only appears in the first bar of the tune. If you play the tune now, you will hear the first three bass notes, corresponding to the first bar.

We are now going to extend this accompaniment to the four bars of the tune.

Tip: While defining the accompaniment, at the bottom of the main window you can directly enter the first and last bars to which the accompaniment should be applied.

Point to the right hand edge of the "Bass line" frame in the accompaniment array (gray).
The mouse pointer changes. Drag the edge to the right to make it cover the four bars of the tune. Release the button. Your accompaniment is now completed.
Play the tune 

Setting up a rhythm


In almost the same way that you created an accompaniment, we are now going to add a rhythm.

Click on the first bar in the rhythm array (green area). The rhythm definition window opens.

Click "Preset" then select "Blues > Classic > blues std 1 (1bar)" in the list and confirm with "OK".

The "blues std 1 (1bar)" rhythm has been inserted in the rhythm array, but only for the first bar. As you did before, extend this rhythm to cover the four bars of your tune.

Play the tune  : your rhythm is heard with the music.
 

Note: Rhythms are played only when the "Rhythms active" icon (tune playing floating palette) is selected

We have just skimmed through the numerous harmonizing features available in Harmony Assistant. Note however that rhythm and accompaniment arrays can be enlarged in height to create several lines that will be played simultaneously.

We advise you to load and carefully examine the examples.

You are invited to view the "Creating automatic accompaniments and rhythms from a melody with Harmony Assistant" video tutorial. ("Windows>Tutorials" menu in the program).


Notation

Introduction



This section of the manual deals with the graphical appearance of the document.

First you will be introduced to the basic concepts of music notation.

Then you will learn how to create a new document from a template.

Several kinds of notation will be mentioned, as well as special kinds of staves: tablatures, multi-voice staves, gregorian notation.

Then, the miscellaneous music symbols that can be related to a staff will be reviewed: break symbols, clefs, key changes...

A dedicated chapter will describe in detail the text objects related to staves: how to input and use them.

Lastly, we will study the free objects and the other tools that help you to improve the score appearance.

 

Musical Theory reminder

General Points

In this program, music is written in the classic way: notes are placed on staves and staves are put together into a score, this being the most common representation in the musical world.

We are now going to review the basics. If you are already familiar with musical theory and vocabulary, you can skip this chapter. 

Note: Of course, the whole of music theory cannot be explained here. To go deeper into this field, you are invited to refer to a specialized book on the subject.
A tune is written in a score (the content of your document's main window). A score is divided into a number of staves, each staff representing what is played by a single instrument.

The staff is made of five grouped horizontal lines:

_________________
_________________
_________________
_________________
_________________


On each staff, notes can be placed. A note defines the sound to be played at a given time by the instrument of the staff. Notes can be placed on or between the lines.

A note, by its appearance and location, defines three parameters:

- Its vertical position defines its pitch. The higher the note is placed, the higher its pitch.

- Its horizontal position defines the time it is played at. Thus, the staff's horizontal axis defines a time scale, passing from left to right. If you place two notes in the same column, they will be played at the same time. This is called a chord.

- The note's shape defines its duration or length. Standard note lengths are predefined in musical notation, each one being twice as long as the next.
 
Thus, you have:
The whole note or semibreve  is equal to two half notes or minims: , each half note is equal to two quarter notes or crotchets. Each quarter note is equal to two eighth notes or quavers: , and so on with sixteenth notes or semiquavers , 32nd notes or demisemiquavers ...


Rests
indicate pauses between notes. Just like notes, they are organized in lengths that decrease by half. Rests are named according to their duration, so you will find a semibreve rest, a minim rest and so on.

Staves are divided into bars, separated by vertical lines placed regularly on the staff. Bars split staves into regular intervals.

Finally, on the left of each staff is a clef. A clef gives several pieces of information:

- Its shape determines where the notes fall on the lines.
Thus, the treble or G clef (upper staff) says that the bottom line corresponds to an E, the space between the two bottom lines to an F, the above line (around which it curls) to a G, and so on for A, B, C, D, E, F, G...
The treble clef symbol is:

With a bass or F clef, the bottom line corresponds to a low-pitched G, and from bottom to top, A, B, C, D, E, F ...
The bass clef symbol is:


- On the right of the clef are two numbers, such as . These indicate the time signature, i.e. the length of each bar. 4/4 means that a bar contains four beats and the value of each beat is a quarter note. Thus the length of the bar is a whole note or two half notes.

divtemps

Musical Theory reminder

Lexicon

A B C D E F G I K N O R S T V

Accent

Just as many written languages employ accents to show how a letter should be pronounced, so musical notation employs accents to indicate phrasing.
Thus, if you see:

Accidental

This is a symbol which modifies the pitch of the note it is linked to, as well as all the subsequent notes in the bar on the same line (or space) of the staff.
There are five accidentals:
  When you see an accidental (sharp, flat...) before a note, that note and all the notes in the same bar and on the same line (or space) are affected.
Most of the time, notes with the same name but in a different octave are also altered. This feature can, however, be turned off in the software in Configuration>Global Setup.

Appoggiatura

This is a little note, placed before another note, which steals its time from the note it is linked to.
When several appogiaturas are linked to a note, they are called Grace notes.

Arpeggio

Notes in an arpeggio chord are not played simultaneously, but successively, very quickly.

Bar


Bars (sometimes called measures) divide a piece of music into equal parts. A bar is subdivided generally into two, three or four parts, called beats.
Not all the beats in a bar have the same importance, depending on the accent:
  Beats are themselves divided into several parts. The first part of a beat is strong, the remainder is weak.

To tell the performer the bar division, two numbers are placed like a fraction after the clef.

The upper number expresses the number of beats in a bar.
The lower number expresses the length of these beats (in fractions of a whole note).

For example, a 3/4 bar comprises three beats each worth a quarter note.

For more information read the Time signature chapter.

Bar line

The bar line is the vertical line which separates each bar from the next.

Chord


A chord is a group of notes played at the same time.

A chord is always related to a scale and is made of at least three notes:
 

With only these three notes, it is already possible to make a significant number of different chords.

Example:
A C major chord, notated C, is made of:

An E minor diminished fifth (or flat fifth), Emb5 will be made of: There are chords made of more than three notes. The software can also use chords of four or five notes, made of the root note, the third and the fifth, but also: For example,

A chord of D minor flat fifth, major seventh, diminished ninth will be notated Dmb5/7Mb9 and made of:

Finally, every chord can be inverted. Inversion changes only the order of notes, never the note values themselves.

Dot


This symbol, placed after a note, increases its duration by half. For example, a dotted quarter note would play for a quarter plus an eighth.
A dot can also be placed after a rest.

Dynamics

Most instruments are capable of being played quietly or loudly. The volume at which passages are played is referred to as ‘dynamics’. The pianoforte is so named because it can play softly or loudly depending on how hard the keys are struck.
In synthesizer speak, the individual note dynamic is called ‘velocity’ because the volume of the note is dependent on the speed of the hand with which it is struck. In this version of the software, dynamics can be set by adjusting the individual velocities of the notes.
For more information, see the Dynamics chapter.

Enharmony

In a scale, notes are distributed in degrees, separated by intervals. The scale of F, for example, comprises F, G, A, Bb, C, D, E, F
But a note can be flat or sharp, so two note names can indicate the same pitch.
Consider the scale of B. This comprises B, C#, D#, E, F#, G# A# B. Here it is appropriate to call the seventh note A#, though it is exactly the same note as the fourth note in the scale of F, which it is more convenient to call Bb. This is enharmony.

Flat (b)


Placed before a note, lowers the pitch by one semitone.

Ghost rest

This notion is specific to Harmony and Melody, and does not exist in regular musical theory.
A ghost rest is a rest used to make up a bar during editing. It indicates an incomplete bar, in which notes can still be added.
It is drawn as:

A ghost rest graphically shows the time remaining in a bar. You can transform ghosts rests to rests by using the staff menu (black triangle in the staff margin), option "Change ghost rests to rests".

 
Tip: ghost rests can be made invisible using an option in Configuration>Global Setup.

Gruppetto

This is a group of three or four little notes before or after the main note. As with grace notes (appoggiatura), their lengths are taken from the note they are linked with.

Inversion

In its fundamental state, the notes of a chord are in the regular order, i.e. the root note is the bottom one, then the third, the fifth and eventually the seventh and the ninth.
Inverting a chord changes this relative order so the bottom note can be any of its notes.

The first inversion shifts the root to the next octave. The third then becomes the bass note of the chord.

The second inversion shifts the root and the third to the next octave. The fifth then becomes the bass note of the chord.

The same principle can be applied for the third and fourth inversions (of course, these inversions only make sense if the chord has four or five notes).

Thus, a C 7th chord, along with its inversions, will comprise:

fundamental state:     C E G Bb
1st inversion:            E G Bb C
2nd inversion:           G Bb C E
3rd inversion:           Bb C E G

It is also possible to make a lower inversion, i.e. shifting notes to the next lower octave.

Here is a summary of the relative order of notes according to the chord inversion.

Nomenclature:
F = Fundamental (root), 3 = third, 5 = fifth, 7 = 7th, 9 = 9th.

              Octave    Octave   Octave
                -1         0        +1
                  .         .         .
fundamental state .         F 3 5 7 9 .
1st inversion     .         . 3 5 7 9 F
2nd inversion     .         .   5 7 9 F 3
3rd inversion     .         .     7 9 F 3 5
4th inversion     .         .       9 F 3 5 7
1st lower inv.   . 3 5 7 9 F         .
2nd lower inv.   .   5 7 9 F 3       .
3rd lower