Myriad Blog 1.3.0 Wednesday, Feb 21st, 2018 at 04:43pm 

Tuesday, Mar 15th, 2016 at 04:58pm
Mac OS X 10.11

 
Voilà plusieurs années que notre Mac de développement est figé sur la dernière version de Mac OS X 10.7. Nous avions déjà évoqué cette obsolescence programmée dans un billet précédent en novembre 2012 :
 
http://www.myriad-online.com/cgi-bin/blog/blog.pl?m=201211
 
Donc à chaque sortie d'une nouvelle version, il nous était impossible de tester sur les versions récentes de Mac OS X et on croisait les doigts...
 
La semaine dernière, un ami nous a proposé un Mac d'occasion remis à neuf par lui-même et ce Mac pouvait accepter Mac OS 10.10 voire 10.11. Bingo !
 
Nous sommes en train de passer nos différents projets sur la nouvelle machine et de tenter de les compiler avec la toute dernière version d'XCode, la 7. Le principal problème est que, fidèle à leur vocation d'obsolescence programmée, Apple ne permet plus de compiler pour d'anciennes versions du système. Or, de notre coté, il est impossible pour nous d'abandonner nos utilisateurs qui sont encore sous 10.5 à 10.8.
 
Une petite bidouille : recopier les anciennes FrameWorks dans le nouveau XCode semble lui faire générer du code compatible, mais c'est à tester en profondeur !
 
by Didier Guillion


Most recent first
Oldest first

Top of page
Legal information Last update:  (c) Myriad