Myriad Forum (http://www.myriad-online.com/cgi-bin/bbs/YaBB.pl)
General >> Galerie >> Slide Show Topic
(Message started by: copious_ken on Feb 28th, 2006, 6:34am)

Title: Slide Show Topic
Post by copious_ken on Feb 28th, 2006, 6:34am
I created a Galerie with slide show for the first time to show off my wedding photos.  This was the first time I have ever used the slide show feature.  I am having a problem that I was hoping you can help me with.

I have set a link on my home page to take visitors to the first picture in the slide show.  When I do this, it acts as if cookies are not enabled.

If you click the link in the slide show to send a visitor to the thumbnails page, and then they click the first slide everything will then act normally and you can start and stop the slide show.

I would like to direct my visitors directly to the first page of the slide show and not to the thumbnails.  Is there a way to do this without encountering this cookies error.

Here is the link I have sent to my visitors.  You can try it and see what I am talking about.  Click 'Index' to go to the thumbnails.

http://robbukar.com/Wedding_2006/pages/page_1.html

Thanks for your help.

Title: Re: Slide Show Topic
Post by Ronald P. Regensburg on Feb 28th, 2006, 12:29pm
I used the link you gave to go directly to the first picture page and the slide show worked fine, without the need to go to the thumbnail page. The only "problem" of bypassing the index page that I see is that the slide show does not need to be started, but is already running.

If you want the slide show to not run already at the first picture page, you can edit that first page adding a script line.

At the top of the page you will find this line:

<script src="galerieslideshow.js" language="javascript" type="text/javascript"></script>

Add another line directly above this line:

<script type="text/javascript" language="JavaScript">document.cookie="galerieslide=0; path=/";</script>
<script src="galerieslideshow.js" language="javascript" type="text/javascript"></script>

A side effect will be that the slide show will stop each time it reaches the first page.

Title: Re: Slide Show Topic
Post by copious_ken on Feb 28th, 2006, 12:46pm
Hmmm, did you try to stop the slide show before you went to the thumbnails page?

If not, close your browser and try the link again.  I believe you did actually encounter the problem because I read in the documentation that if cookies are not enabled the slide show will start automatically.  If you try to hit the stop button it will not work.  This is my problem.

Once you go to the thumbnails page and then return to the slide show by clicking a thumbnail, you can then stop the slide show.

Thanks.

Title: Re: Slide Show Topic
Post by Ronald P. Regensburg on Feb 28th, 2006, 1:14pm
I see what you mean. I did not try to stop the slide show, I did not go the the index page either.

Anyway, the solution I suggested will solve that problem, it adds the cookie that normally will be added by accessing picture pages from the index page.

Title: Re: Slide Show Topic
Post by copious_ken on Feb 28th, 2006, 5:33pm
thanks.  It works now, with your suggestion

Title: Re: Slide Show Topic
Post by emmy on Nov 12th, 2016, 1:05pm

on 02/28/06 at 12:29:57, Ronald P. Regensburg wrote:
I used the link you gave to go directly to the first picture page and the slide show worked fine, without the need to go to the thumbnail page. The only "problem" of bypassing the index page that I see is that the slide show does not need to be started, but is already running.

If you want the slide show to not run already at the first picture page, you can edit that first page adding a script line.

At the top of the page you will find this line:

<script src="galerieslideshow.js" language="javascript" type="text/javascript"></script>

Add another line directly above this line:

<script type="text/javascript" language="JavaScript">document.cookie="galerieslide=0; path=/";</script>
<script src="galerieslideshow.js" language="javascript" type="text/javascript"></script>

A side effect will be that the slide show will stop each time it reaches the first page.


Hi! Thank you for your effort. I have tried edit the slides on myriad but the first picture isn't showing... Pls how can resolve that? Thanks



Myriad Forum » Powered by YaBB 1 Gold - SP 1.1!
YaBB 2000-2002,
Xnull. All Rights Reserved.